sentry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sp...@apache.org
Subject sentry git commit: SENTRY-1893: Bump the minimum java version to 8 (Sergio Pena and Hrishikesh Gadre, reviewed by Alexander Kolbasov)
Date Fri, 13 Oct 2017 22:08:43 GMT
Repository: sentry
Updated Branches:
  refs/heads/master 6aacd830a -> bbedb2ad6


SENTRY-1893: Bump the minimum java version to 8 (Sergio Pena and Hrishikesh Gadre, reviewed
by Alexander Kolbasov)


Project: http://git-wip-us.apache.org/repos/asf/sentry/repo
Commit: http://git-wip-us.apache.org/repos/asf/sentry/commit/bbedb2ad
Tree: http://git-wip-us.apache.org/repos/asf/sentry/tree/bbedb2ad
Diff: http://git-wip-us.apache.org/repos/asf/sentry/diff/bbedb2ad

Branch: refs/heads/master
Commit: bbedb2ad660cc1b11b04d73d94953052fc325823
Parents: 6aacd83
Author: Sergio Pena <sergio.pena@cloudera.com>
Authored: Fri Oct 13 17:07:47 2017 -0500
Committer: Sergio Pena <sergio.pena@cloudera.com>
Committed: Fri Oct 13 17:07:47 2017 -0500

----------------------------------------------------------------------
 pom.xml | 29 +++--------------------------
 1 file changed, 3 insertions(+), 26 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/sentry/blob/bbedb2ad/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index a028912..c6a94d5 100644
--- a/pom.xml
+++ b/pom.xml
@@ -52,8 +52,8 @@ limitations under the License.
   <properties>
     <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
     <buildtools.dir>${basedir}/build-tools</buildtools.dir>
-    <maven.compile.source>1.7</maven.compile.source>
-    <maven.compile.target>1.7</maven.compile.target>
+    <maven.compile.source>1.8</maven.compile.source>
+    <maven.compile.target>1.8</maven.compile.target>
     <failIfNoTests>false</failIfNoTests>
     <!-- versions are in alphabetical order -->
     <ant.contrib.version>1.0b3</ant.contrib.version>
@@ -656,7 +656,7 @@ limitations under the License.
           <linkXRef>false</linkXRef>
           <includeTests>true</includeTests>
           <verbose>true</verbose>
-          <targetJdk>1.7</targetJdk>
+          <targetJdk>${maven.compile.target}</targetJdk>
           <excludeRoots>
             <excludeRoot>${basedir}/src/main/generated</excludeRoot>
           </excludeRoots>
@@ -763,30 +763,7 @@ limitations under the License.
           <configuration>
             <source>${maven.compile.source}</source>
             <target>${maven.compile.target}</target>
-            <!-- Enable errorprone compiler - see
-                 http://errorprone.info
-            -->
-            <compilerId>javac-with-errorprone</compilerId>
-            <forceJavacCompilerUse>true</forceJavacCompilerUse>
           </configuration>
-          <dependencies>
-            <dependency>
-              <groupId>org.codehaus.plexus</groupId>
-              <artifactId>plexus-compiler-javac-errorprone</artifactId>
-              <version>2.8</version>
-            </dependency>
-            <!-- override plexus-compiler-javac-errorprone's dependency on
-                 Error Prone version 2.05.
-                 NOTE: We can only use version 2.05 - subsequent versions
-                       use Java 8. Once Sentry build switches to Java 8, we
-                       can update this to a newer version.
-            -->
-            <dependency>
-              <groupId>com.google.errorprone</groupId>
-              <artifactId>error_prone_core</artifactId>
-              <version>2.0.5</version>
-            </dependency>
-          </dependencies>
         </plugin>
         <plugin>
           <groupId>org.apache.maven.plugins</groupId>


Mime
View raw message