santuario-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colm O hEigeartaigh <cohei...@apache.org>
Subject Java 2.1.0 release?
Date Wed, 28 Sep 2016 14:17:13 GMT
Hi all,

I'm trying to figure out if it makes sense, or if there's any interest, in
a 2.1.0 release of the Java library. 2.0.x requires Java 6. I'm thinking
that we could skip Java 7 and require only Java 8 onwards for 2.1.x. Off
hand I can think of the following benefits:

 - Java 9 support
 - Replace the Base64 implementation with the Base64Encoder/Decoder in JDK
1.8
 - Implement try-with-resources
 - ?

Any opinions on this? Any changes anyone would like to see that potentially
break backwards compatibility?

Colm.


-- 
Colm O hEigeartaigh

Talend Community Coder
http://coders.talend.com

Mime
View raw message