santuario-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Johnson <e...@tibco.com>
Subject Re: What's the minimum JRE version supported by Santuario Java, versions 1.5.X?
Date Tue, 04 Dec 2012 21:55:42 GMT
Hmmm - OK. For a patch I'm pulling together, I'm including the @Override 
annotation on methods implementing an interface-defined method. OK for 
targeting 1.6, but not for targeting 1.5.

Since my patch is targeted at trunk, shouldn't be a problem, but won't 
be as easy to back-port.

Eric.

On 12/4/12 3:20 AM, Colm O hEigeartaigh wrote:
>
> The minimum Java version for the 1.5.x series of releases is 1.5. For 
> trunk the minimum JDK version is 1.6.
>
> Colm.
>
> On Mon, Dec 3, 2012 at 6:14 PM, Eric Johnson <eric@tibco.com 
> <mailto:eric@tibco.com>> wrote:
>
>     For some reason, I thought it was Java 1.5.
>
>     I notice that the POM on trunk seems to indicate 1.6 as the target.
>
>     Which is it? 1.5 or 1.6 as the minimum?
>
>     I couldn't see this information displayed anywhere on the web site
>     for the project, either.
>
>     Eric.
>
>
>
>
> -- 
> Colm O hEigeartaigh
>
> Talend Community Coder
> http://coders.talend.com
>


Mime
View raw message