santuario-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Cantor" <canto...@osu.edu>
Subject RE: Xml-security-c 1.5.x won't compile under Cygwin [SEC=UNCLASSIFIED]
Date Fri, 25 Sep 2009 01:02:45 GMT
Hill, Shane wrote on 2009-09-24:
> Has anyone had this issue of not being able to compile xml-security-c
> 1.5.0 or 1.5.1 under Cygwin? Something to do with DLL import/export.
> Very nasty ... should not need this under Cygwin. Just treat a Cygwin
> compile just like it were Linux and all should be fine. Except I can't
> seem to get the makefile structure to allow me to do this ... Yet.

Whatever you're doing is not the right thing, you're pulling in Xerces
headers based on MSVC and they're defining the macros properly for standard
Windows builds. The xmlsec macros depend on those directly.

You have to use a configure-based build certainly, all the way down the
stack.

None of which is to say this will work on cygwin no matter what you do, but
that's the reason you're getting errors.

-- Scott



Mime
View raw message