santuario-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Werner Dittmann <Werner.Dittm...@t-online.de>
Subject Re: Unable to decrypt using JRE6
Date Wed, 20 May 2009 11:08:32 GMT
Seems that it is a problem with the JCE policy files that block
strong cryptography?

After every update of Java runtime you need to re-install the
crypto policy files again.

Regards,
Werner

Deepachandaran Palanisamy schrieb:
> Hi,
>   
>  I am doing XML encryption/decryption using xmlsec-1.2.97.jar.
>   
>  I used to encrypt in client side using  JRE1.4(Java Runtime 
>  Environment) VM & decrypt in JRE1.4 on another VM on server side.
>   
>  Everything was going fine if client & server both uses JRE1.4.
>   
>  Now the server side VM is upgraded to JRE1.6 where decryption 
>  happens.Now decryption is getting failed & throws below error
>   
>  java.security.InvalidKeyException: Wrong algorithm: AES or Rijndael
> required
>   at org.apache.xml.security.encryption.XMLCipher.
>  decryptToByteArray(Unknown Source)
>   at org.apache.xml.security.encryption.XMLCipher.
>  decryptElement(Unknown Source)
>   at org.apache.xml.security.encryption.XMLCipher.doFinal(Unknown Source)
>   
>  Please advice.
>  
>  -Deepak
> 


Mime
View raw message