santuario-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Novotny <r.novo...@szm.sk>
Subject Re: Upload 1.4.1 and 1.4.2 to Maven Repo
Date Thu, 11 Sep 2008 06:37:19 GMT

The official Maven repo seems to have picked up the new JARs. ( See
http://repo1.maven.org/maven2/org/apache/santuario/xmlsec/1.4.1/ )

Thanks for help!

I'm going to notify the Spring-WS developers to upgrade the dependencies.





Sean Mullan wrote:
> 
> Robert Novotny wrote:
>> I am just a poor Santuario user knowing nothing about the repository
>> upload
>> mechanism.
>> 
>> However, I believe, that Maven repo is synchronized with Apache
>> repository,
>> which is 
>> 
>> http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/apache/santuario/xmlsec/
>> 
>> See maven repository configuration file below [1]. Therefore I think if
>> someone has the access to the Apache repository (which even contains an
>> empty directory for 1.4.1), the Maven repo will synchronize
>> automatically.
> 
> Ok, I just uploaded the 1.4.1 and 1.4.2 jars to the apache maven
> repository:
> 
> http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/apache/santuario/xmlsec/1.4.1/
> http://people.apache.org/repo/m2-ibiblio-rsync-repository/org/apache/santuario/xmlsec/1.4.2/
> 
> Let me know if there are any problems.
> 
>> 
>> Besides that, Santuario project page states, that the libraries can be
>> downloaded only from the official sites (no mirrors). Why is that? Are
>> there
>> any legal reasons not to broadcast Santuario to the official Apache
>> mirrors?
> 
> I am not exactly sure why that is. I'm hoping one of the committers who
> has been 
> around longer than I knows why ... maybe Berin?
> 
> --Sean
> 
>> 
>> [1]
>> https://svn.apache.org/repos/asf/maven/repository-tools/trunk/src/bin/synchronize/m2-sync/sync.csv
>> 
>> 
>> Sean Mullan wrote:
>>> If you tell me how to upload it, I'll look into it.
>>>
>>> --Sean
>>>
>>> Robert Novotny wrote:
>>>> Hello,
>>>> I notice that the last version in the Maven repository is 1.4.0?
>>>> Version
>>>> 1.4.1 fixes major bug with UTF-8 (which makes 1.4.0 unusable with
>>>> messages
>>>> containing international characters).
>>>>
>>>> XML Security is used in the Spring-WS project. However, Spring-WS
>>>> cannot
>>>> update its dependency until a new version of XML Security appears in
>>>> the
>>>> Maven repo.
>>>>
>>>> Are there any plans fixing this?
>>>>
>>>> Robert Novotny
>>>
>>>
>> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Upload-1.4.1-and-1.4.2-to-Maven-Repo-tp19387238p19428720.html
Sent from the Apache XML - Security - Dev mailing list archive at Nabble.com.


Mime
View raw message