santuario-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Cantor" <canto...@osu.edu>
Subject RE: xml-security-c1.4 and freebsd
Date Tue, 17 Jun 2008 16:25:56 GMT
> last output lines:
> [...]
> checking for Xerces 2.x or 3.x headers in XERCESCROOT/include... found
> checking for Xerces 2.x or 3.x library naming convention... unable to
> determine
> configure: error: cannot link to Xerces library

Check the log (jeesh, I wish configure would just *say* that when it errors
out, it would save so much email).

> xerces is xerces-c-src_2_8_0 installed in /opt/shibboleth-sp
> some env:
> 
> XERCESCROOT=/usr/local/src/xerces-c-src_2_8_0

That's not necessary for building xmlsec anymore, and you can use
--with-xerces if you need to.

> CPPFLAGS=-I/opt/shibboleth-sp/include/xercesc/
> LDFLAGS=-L/opt/shibboleth-sp/lib/

As a rule, NEVER manually set those to values that configure should be
getting through "proper" options. It just confuses the scripts.

> I'm sure I'm doing something wrong. Unfortunately I'm a newcomer.

Well, the code you're trying to build is not supported on FreeBSD, so
consider whether that's even something you can deal with anyway.

-- Scott



Mime
View raw message