santuario-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 44999] DOMException is thrown at XMLSignature creation (1 .4.2 beta2)
Date Thu, 15 May 2008 19:17:14 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=44999


sean.mullan@sun.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED




--- Comment #1 from sean.mullan@sun.com  2008-05-15 12:17:14 PST ---
Thanks for catching this regression!

> Possible fix:
> -------------
> In case of "" prefix, ElementProxy.setDefaultPrefix() should put either "xmlns"
> or "" to the _prefixMappingsBindings Map.

My fix puts "xmlns" into the map. It seemed more logical.

> Or, maybe, different checks should be performed at XMLSignature:200-208 and
> similar places, first getting ElementProxy.getDefaultPrefix(namespace); and
> then, if it is not empty, calling
> ElementProxy.getDefaultPrefixBindings(namespace). Something like in
> ElementProxy.createElementForFamily():136-152.

Yes, you could do that, but I chose the mapping fix because that is where the
bug really is.

> Assignment XMLUtils.xmlnsDsPrefix="xmlns:"+prefix; (ElementProxy:516) should
> probably be fixed as well (not sure; however, it seems the variable
> xmlnsDsPrefix is not used at all).

I removed the xmlnsDsPrefix variable.

Incidentally, I found the same problem if you are using the JSR 105 API and set
the namespace prefix to "" using the XMLSignContext.putNamespacePrefix method.
I have fixed that as well. 

Both of these fixes will be in 1.4.2.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message