santuario-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Cantor" <canto...@osu.edu>
Subject C++ library checking openssl version properly?
Date Mon, 21 Aug 2006 20:01:52 GMT
Either the config header in 1.3RC is off, or I'm missing something. The code
in the Win32 config header looks like:

#	if (OPENSSL_VERSION_NUMBER >= 0x00907000)
#		define XSEC_OPENSSL_CONST_BUFFERS
#		define XSEC_OPENSSL_HAVE_AES
#		define XSEC_OPENSSL_CANSET_PADDING
#		define XSEC_OPENSSL_HAVE_CRYPTO_CLEANUP_ALL_EX_DATA
#	endif
#	if (OPENSSL_VERSION_NUMBER >= 0x00908000)
#		define XSEC_OPENSSL_D2IX509_CONST_BUFFER
#	endif

However, none of this stuff is being defined that I can tell, because my
copy of openssl 0.9.8 has this:

#define OPENSSL_VERSION_NUMBER	0x0090801fL

It's too small a number, as there's an extra zero in the XSEC config header.

-- Scott


Mime
View raw message