santuario-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Siegfried Goeschl <siegfried.goes...@it20one.at>
Subject Re: first run, xalan problems?
Date Mon, 07 Mar 2005 16:21:12 GMT
Hi Peter,

as a newbie I'm not sure but it looks like a problem with your 
registered JCE providers - DESEDEWRAP is provided by SunJGSS 1.0 and BC 
(on my box running JDK 1.4.2)

Cheers,

Siegfried Goeschl


Peter Wayner wrote:

>
>
> Hi--
>
> I can only get a few of the ANT targets to work on the latest version 
> of the XML-Security, even after moving a copy of the Xalan library to 
> the endorsed folder.
>
> If anyone can suggest a fix, I would be grateful. Thanks.
>
> Here's what the ant build error looks like when I try to run ANT 
> target encrypt:
>
>
> Exception in thread "main" 
> org.apache.xml.security.encryption.XMLEncryptionException: Cannot find 
> any provider supporting DESedeWrap
> [Encrypter] Original Exception was 
> java.security.NoSuchAlgorithmException: Cannot find any provider 
> supporting DESedeWrap
> [Encrypter] at 
> org.apache.xml.security.encryption.XMLCipher.getInstance(Unknown Source)
> [Encrypter] at 
> org.apache.xml.security.samples.encryption.Encrypter.main(Unknown Source)
> [Encrypter] java.security.NoSuchAlgorithmException: Cannot find any 
> provider supporting DESedeWrap
> [Encrypter] at javax.crypto.Cipher.getInstance(DashoA6275)
> [Encrypter] at 
> org.apache.xml.security.encryption.XMLCipher.getInstance(Unknown Source)
> [Encrypter] at 
> org.apache.xml.security.samples.encryption.Encrypter.main(Unknown Source)
> BUILD FAILED: 
> /Applications/eclipse/workspace/xml-security2/build.xml:432: Java 
> returned: 1
>
>



Mime
View raw message