samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Erickson <ja...@stormpath.com>
Subject Re: Samza task not receiving on one partition
Date Tue, 26 Apr 2016 01:41:05 GMT
My earlier answer to this was replying to the wrong message.  I am
launching this with ThreadJobFactory.

On Mon, Apr 25, 2016 at 4:26 PM Jagadish Venkatraman <jagadish1989@gmail.com>
wrote:

> Are you running in Yarn or as a local process?
>
> If you're running in Yarn, you can use the AppMaster UI to see what the
> jobmodel is.
>
> On Mon, Apr 25, 2016 at 2:33 PM, Jason Erickson <jason@stormpath.com>
> wrote:
>
> > I have a puzzling issue with one of my samza tasks. It works correctly
> > except for messages on one partition. I have 9 partitions on the topic.
> If
> > I send 1000 messages, I only receive about 890 of them. I have checked
> with
> > kafka-console-consumer with partition keys that I know don’t get
> processed
> > by my samza job and the console consumer DOES see the message, so I know
> > it’s getting written to the topic and that at least a vanilla consumer
> can
> > see it just fine.
> >
> >
> > I’m happy to share whatever interesting configuration information would
> > help narrow this down, but right now, I’m a bit mystified about what I
> > would even share.
> >
> >
> >  I’m running
> >
> > * samza-kafka_2.10 version 0.9.1
> >
> > * kafka_2.10 version 0.8.2.1 on the client
> >
> > * kafka broker 0.9.0.0
> > ​
> >
>
>
>
> --
> Jagadish V,
> Graduate Student,
> Department of Computer Science,
> Stanford University
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message