samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yan Fang <yanfang...@gmail.com>
Subject Re: Nothing occurs from collector.send()
Date Tue, 02 Jun 2015 23:56:20 GMT
Hi Garrett,

I guess you run into the serde issues as you mentioned. If you can check
the Samza log and show us, we will be more helpful. Also, maybe pasting the
config here (if you dont mind), we can help to see if you miss something.

Thanks,

Fang, Yan
yanfang724@gmail.com

On Tue, Jun 2, 2015 at 3:01 PM, Garrett Barton <garrett.barton@gmail.com>
wrote:

> Greetings all,
>
>
>  I am trying to translate an existing workflow from MR into Samza. Thus far
> everything is coded and kinks with deploying have been worked out.  My task
> deploys into yarn (2.6.0), consumes records from Kafka (0.8.2.1) fine, but
> no data from metrics and my output streams are showing up in Kafka.  I see
> the metrics topic created in Kafka, but its empty (I have a counter
> counting records seen).
>
>  I have debug prints showing me that I am calling collector.send() which is
> also wrapped in a catch for Throwable.  Nothing at all shows in the logs.
>
>  I do see the checkpoint topic being used, and incremented appropriately.
> So between that and consuming records in the first place I think the
> system.kafka is configured correctly.  I ran into serde issues with
> consumption and sending and fixed those too.
>
> Has anyone run into this kind of behavior?  Am hoping its a dumb config
> issue.
>
> V/R,
> ~Garrett
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message