samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Riccomini <criccom...@linkedin.com.INVALID>
Subject Re: YARN UI does not work
Date Thu, 30 Oct 2014 20:43:36 GMT
Hey Guys,

I looked into this a bit. Two things:

1. The bash -x -e command in vagrant/bootstrap.sh didn't work. I had to
remove the -e switch.
2. conf/yarn-site.xml forces YARN to bind to 127.0.0.1. This means that
192.168.0.20:8088/cluster/apps doesn't work. Eliminating the
yarn.resourcemanager.hostname property fixed this.

Once I did that, I still couldn't contact 192.168.0.20 from my host
machine. I suspect there's some configuration that needs to be set (or
removed) to make this work. Given that we don't have any owner for this
code right now, I'm going to remove it.

Cheers,
Chris

On 10/30/14 9:15 AM, "Yan Fang" <yanfang724@gmail.com> wrote:

>-- Hi Zeel,
>
>I think currently the Vagrant tutorial has some issues as we described in
>https://issues.apache.org/jira/browse/SAMZA-189 . The workaround are:
>
>option 1: in your local machine, do as this tutorial
>http://samza.incubator.apache.org/startup/hello-samza/0.7.0/
>
>option 2: if you do not want to use your local machine, since you already
>have the VB, you could use the CDH quickstart VM as a replacement.
>http://www.cloudera.com/content/cloudera/en/downloads/quickstart_vms/cdh-5
>-2-x.html
>. Thought it's a little big, it contains a lot of stuff that a cluster
>will
>contain ( 1 node cluster. ) . Then do as the tutorial.
>http://samza.incubator.apache.org/startup/hello-samza/0.7.0/ . One
>difference is that, instead of running  "bin/grid bootstrap", you only
>need
>to run "bin/grid install kafka" and "bin/grid start kafka", because this
>VM
>already contains Yarn and Zookeeper.
>
>option 3: if you want to test the Samza in a cluster, Chris has a good
>tutorial about how to set up the cluster by yourself.
>http://samza.incubator.apache.org/learn/tutorials/0.7.0/run-in-multi-node-
>yarn.html
>
>-- Hi Shekar,
>
>If you are using Vagrant, I think it does have some issues. Maybe you
>could
>do as option 1 and option 2. :)
>
>
>Hope the late reply can help you. Thanks.
>
>Cheers,
>
>Fang, Yan
>yanfang724@gmail.com
>+1 (206) 849-4108
>
>On Wed, Oct 29, 2014 at 1:39 PM, Yan Fang <yanfang724@gmail.com> wrote:
>
>> So seems currently the workaround is to install the YARN by running
>>*bin/grid
>> install yarn* .
>>
>> Fang, Yan
>> yanfang724@gmail.com
>> +1 (206) 849-4108
>>
>> On Wed, Oct 29, 2014 at 11:07 AM, Chris Riccomini <
>> criccomini@linkedin.com.invalid> wrote:
>>
>>> Hey All,
>>>
>>> It sounds like the virtual machine path is busted. We either need to
>>>fix
>>> it or remove it. This topic is discussed here:
>>>
>>>   https://issues.apache.org/jira/browse/SAMZA-189
>>>
>>> Cheers,
>>> Chris
>>>
>>> On 10/29/14 11:05 AM, "Shekar Tippur" <ctippur@gmail.com> wrote:
>>>
>>> >Yan,
>>> >
>>> >I am running it on a virtual machine.
>>> >
>>> >- Shekar
>>> >
>>> >On Wed, Oct 29, 2014 at 11:00 AM, Yan Fang <yanfang724@gmail.com>
>>>wrote:
>>> >
>>> >> Hi Zeel and Shekar,
>>> >>
>>> >> Are you both running this in VirturalBox or in your local machine? I
>>> >>want
>>> >> to know if it's related to the VM or the hello-samza because I can
>>> >> successfully run it in my local machine as well as CDH VM.
>>> >>
>>> >> Cheers,
>>> >>
>>> >> Fang, Yan
>>> >> yanfang724@gmail.com
>>> >> +1 (206) 849-4108
>>> >>
>>> >> On Wed, Oct 29, 2014 at 9:44 AM, Shekar Tippur <ctippur@gmail.com>
>>> >>wrote:
>>> >>
>>> >> > Chris,
>>> >> >
>>> >> > I couldnt get yarn to work .. so had to resort to LocalJob.
>>> >> >
>>> >> > - Shekar
>>> >> >
>>> >> > On Wed, Oct 29, 2014 at 8:47 AM, Chris Riccomini <
>>> >> > criccomini@linkedin.com.invalid> wrote:
>>> >> >
>>> >> > > Hey Shekar,
>>> >> > >
>>> >> > > Running with LocalJobFactory will run Samza without YARN.
You
>>>can
>>> do
>>> >> > this,
>>> >> > > it just means you won't be running with YARN.
>>> >> > >
>>> >> > > Cheers,
>>> >> > > Chris
>>> >> > >
>>> >> > > On 10/29/14 8:34 AM, "Shekar Tippur" <ctippur@gmail.com>
wrote:
>>> >> > >
>>> >> > > >I had a similar problem which I am still grappling with.
>>> >> > > >I had to change the property to local.
>>> >> > > >job.factory.class=org.apache.samza.job.local.LocalJobFactor
>>> >> > > >
>>> >> > > >
>>> >> > > >- Shekar
>>> >> > > >
>>> >> > > >On Tue, Oct 28, 2014 at 9:39 PM, Zeel Shah
>>> >><zeel.shah3190@gmail.com>
>>> >> > > >wrote:
>>> >> > > >
>>> >> > > >> Hello,
>>> >> > > >>     I am trying to run hello samza but Yarn UI does
not show
>>>up
>>> >>on
>>> >> > > >> localhost:8088.
>>> >> > > >>
>>> >> > > >> Attempts:
>>> >> > > >>
>>> >> > > >> 1) Followed the steps on
>>> >> > > >>
>>> >> > > >>
>>> >> > > >>
>>> >> > >
>>> >> >
>>> >>
>>> >>
>>> 
>>>http://samza.incubator.apache.org/learn/documentation/latest/comparisons
>>>/
>>> >> > > >>introduction.html
>>> >> > > >>
>>> >> > > >> Failure - YARN UI did not show up.
>>> >> > > >>
>>> >> > > >> 2) Followed steps on
>>> >> > > >>
>>> >> > > >>
>>> >> >
>>> >>
>>> 
>>>https://github.com/apache/incubator-samza-hello-samza/blob/master/README
>>> >> > > .
>>> >> > > >>md
>>> >> > > >>
>>> >> > > >> Failure  - stdin: is not a tty.
>>> >> > > >> VM is running after this failure but YARN, ZOOKEEPER,
KAFTA
>>>have
>>> >>not
>>> >> > > >>been
>>> >> > > >> installed on it.
>>> >> > > >>
>>> >> > > >> Please let me know where am i going wrong or what
could be
>>>the
>>> >> > potential
>>> >> > > >> issues.
>>> >> > > >>
>>> >> > > >> Thanks in advance.
>>> >> > > >>
>>> >> > > >> Regards,
>>> >> > > >> Zeel.
>>> >> > > >>
>>> >> > >
>>> >> > >
>>> >> >
>>> >>
>>>
>>>
>>


Mime
View raw message