samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Garry Turkington <g.turking...@improvedigital.com>
Subject RE: [DISCUSS] Remove support for Scala 2.9?
Date Tue, 14 Oct 2014 15:14:47 GMT
I'd be +1 here -- generally I like getting rid of supported platforms. And being purely selfish
I have no code relying on 2.9 so it's not an impact to me. 

Garry

-----Original Message-----
From: Jakob Homan [mailto:jghoman@gmail.com] 
Sent: 14 October 2014 01:12
To: dev@samza.incubator.apache.org
Subject: [DISCUSS] Remove support for Scala 2.9?

Recent tickets have been opened regarding Scala 2.9 code that's preventing compilation on
2.11.  (https://issues.apache.org/jira/browse/SAMZA-163,
https://issues.apache.org/jira/browse/SAMZA-430).  2.9 came out in 2011 and at this point
is pretty ancient.

Any opposition to removing support for 2.9 and focusing on 2.10 and above?
I'd be +1.

-jakob

-----
No virus found in this message.
Checked by AVG - www.avg.com
Version: 2014.0.4765 / Virus Database: 4040/8380 - Release Date: 10/13/14
Mime
View raw message