rya-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fan Yang <fya...@umbc.edu>
Subject Re: Maven Build Error
Date Wed, 02 Dec 2015 07:25:48 GMT
Hi Aaron,

Sorry to bother you again. I faced a new problem in loading RDF data process. Following the
tutorial, I created loadrdf folder and N-Triples file $RDF_DATA, when I complied and run the
java code, it gave the error message like :”java.io.IOException: Server returned HTTP response
code: 500 for URL: http://localhost:8080/web.rya/loadrdf/?format=N-Triples” my tomcat host
server’s URL is localhost and port number is 8080 by default. 

Also another question is about bulk load RDF data. There is an example code in the tutorial,
I’ve tried to find the similar jar package named accumulo.rya-3.0.4-SNAPSHOT-shaded.jar,
unfortunately the only one I could found is accumulo.rya-3.2.10-SNAPSHOT.jar and when I replaced
the code with this one, it said it’s not a valid jar.

Please let me know if I misunderstood and did anything wrong with the tutorial, thank you
very much!

Bests,

Fan
 
> On Nov 19, 2015, at 1:24 PM, Aaron D. Mihalik <mihalik@alum.mit.edu> wrote:
> 
> Hey Fan.  Are you on the dev list?  I didn't do a "reply-all"...
> 
> My response to your email this morning is below. 
> 
> ---------- Forwarded message ---------
> From: Aaron D. Mihalik <mihalik@alum.mit.edu <mailto:mihalik@alum.mit.edu>>
> Date: Thu, Nov 19, 2015 at 8:47 AM
> Subject: Re: Maven Build Error
> To: <dev@rya.incubator.apache.org <mailto:dev@rya.incubator.apache.org>>
> 
> 
> Hey Fan!
> 
> Thanks for downloading Rya and testing it out.
> 
> It appears that you must use Maven 3 (for kinda a funny reason... it'll hit the apache
repo by default), and it appears that there are some test issues with mvm.rya.accumulo.AccumuloRyaDAOTest.
> 
> You should be able to build rya using this command (with maven 3): mvn clean install
-DskipTests
> 
> Regardless, we need to create an ticket to fix your broken test.  Could you send out
your test report?  Specifically, we're interested in : dao/accumulo.rya/target/surefire-reports/mvm.rya.accumulo.AccumuloRyaDAOTest.txt
> 
> --Aaron
> 
> 
> On Thu, Nov 19, 2015 at 7:28 AM Fan Yang <fyang1@umbc.edu <mailto:fyang1@umbc.edu>>
wrote:
> Hi,
> 
> My name is Fan Yang, I am a phd student in Information Systems Department, UMBC. Currently
I am working on Rya project under the supervision of Dr. Adina. I faced a problem when I tried
to reproduce the development environment on my virtual machine.
> 
> When I built Rya project by Maven, it gave me some error report and same thing happened
even I tried different versions of Maven. I am attaching the log files generated by Maven
3.3.3 (log333.txt) and Maven 2.2.1 (log221.txt) and looking for some help. Thank you so much!
> 
> My development environment is:
> 
> OS: Hortonworks Sandbox with HDP 2.2.4 (Cent OS 6 64bit)
> Maven version: 3.3.3
> Java version: OpenJDK Runtime Environment 1.7.0_79
> Accumulo version: 1.6.1.2.2.4.2-2
> Hadoop version:2.6.0.2.2.4.2-2
> 
> Bests,
> 
> Fan
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message