royale-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Cruz" <car...@nbtbizcapital.com>
Subject RE: FlexJS SDK
Date Mon, 30 Oct 2017 03:38:23 GMT
Thx!!

Sorry if this is something I overlooked and wasted some of your time, I thought changing the
target JRE and creating a new project would’ve taken care of this since I was already using
Java 1.8. 

 

As per the instructions I copied JRE 1.8.xxx into the FB…jre directory and the errors went
away! 

 

Thx again!!

Carlos

 

From: Alex Harui [mailto:aharui@adobe.com] 
Sent: Sunday, October 29, 2017 10:58 PM
To: users@royale.apache.org
Subject: Re: FlexJS SDK

 

Hi Carlos,

 

See: https://cwiki.apache.org/confluence/display/FLEX/Using+FlexJS+with+Adobe+Flash+Builder

 

Where it says: 

 

Also, starting with Apache FlexJS 0.8.0, you will need to have upgraded Flash Builder to run
on Java 7 or 8.  See  <http://blogs.adobe.com/flashplayer/2016/09/running-adobe-flash-builder-on-mac-with-java-78.html#sthash.A7Gi2Th5.dpbs>
http://blogs.adobe.com/flashplayer/2016/09/running-adobe-flash-builder-on-mac-with-java-78.html

 

Someday we'll get this information ported over to Royale.

 

Thanks

-Alex

 

From: Carlos Cruz <carlos@nbtbizcapital.com <mailto:carlos@nbtbizcapital.com> >
Reply-To: "users@royale.apache.org <mailto:users@royale.apache.org> " <users@royale.apache.org
<mailto:users@royale.apache.org> >
Date: Sunday, October 29, 2017 at 1:25 PM
To: "users@royale.apache.org <mailto:users@royale.apache.org> " <users@royale.apache.org
<mailto:users@royale.apache.org> >
Subject: RE: FlexJS SDK

 

Thanks for the input, but the Flex compiler does not have an option “target” (I don’t
think so anyways) although I don’t think this is the problem I did try changing the JRE
compliance 1.6 and 1.7, FB does not seem to recognize JRE 1.8 (Windows -> preferences ->
Java -> compilers -> JDK compliance) .

 

I think the issue is with flexJS 0.8.0 itself because FlexJS 0.7.0 does not give an error.

 

Thx!

Carlos

 

From: Justin Mclean [mailto:justin@classsoftware.com] 
Sent: Sunday, October 29, 2017 1:16 PM
To: users@royale.apache.org <mailto:users@royale.apache.org> 
Subject: Re: FlexJS SDK

 

Hi,






Flash Builder 4.7 

Message: Uncaught exception in compiler Plug-in: com.adobe.flexbuilder.project

Exception stack trace:

ava.lang.UnsupportedClassVersionError: com/google/javascript/jscomp/ErrorManager : Unsupported
major.minor version 51.0

 

Looks like Flash Builder is getting java 7 (i.e. version 51) but is expecting Java 6 trying
"-target 1.6” as a compiler option may fix it.

 

Thanks,

Justin


Mime
View raw message