royale-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Rovira <carlosrov...@apache.org>
Subject Re: ***UNCHECKED*** Re: [Discuss] Start release process 0.9.3
Date Thu, 04 Oct 2018 08:59:43 GMT
Hi Harbs,

for me Maven is not easier, seems as difficult as ANT. For me the points
for maven is the reliability and robustness of the build process and the
management of dependencies. ANT was the first step for me, and I always
liked, but the problems was that it was more a way to script than something
that follows a protocol and manage the download of packages (and ensure
that package are the exact bits you need).

We have a use case when build the SDK with ANT in Royale. You and Alex gets
flexunit and uses the as3 swc. Erik and I do the same and we end using the
flex swc. Why? This is cause is all hand made script and probably we have
some configuration differences in our environments that make the script
behave different. The fact is that I still could not find the black point
after some hours of digging.

This is something that should not happen in Maven (well, you always can
make maven do things badly as with any technology). Maven as all tools, can
make things more or less easy, but once you have the things correctly setup
should manage all the needed dependencies and be more reliable in all
environments. But don't expect to be more easy than working with ANT, since
for a project with the size of Royale both build systems are complex.

Just my 2


El jue., 4 oct. 2018 a las 10:24, Harbs (<harbs.lists@gmail.com>) escribió:

> Can I ask a dumb question?
>
> Why are we using Maven for release? The argument I’ve always heard is that
> Maven is easier. This doesn’t seem easy… ;-)
>
> Harbs
>
> > On Oct 4, 2018, at 11:09 AM, Piotr Zarzycki <piotrzarzycki21@gmail.com>
> wrote:
> >
> > Neverending story ;) What's your internet connection actually?
> >
> > On Thu, Oct 4, 2018, 10:04 AM OmPrakash Muppirala <bigosmallm@gmail.com>
> > wrote:
> >
> >> Hmm, failed again at a different spot:
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Themes:
> >> Jewel-Dark-NoFlat-Emphasized-Sunflower-Theme SUCCESS [ 22.251 s]
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Themes:
> >> Jewel-Dark-NoFlat-Emphasized-Topaz-Theme SUCCESS [ 18.741 s]
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Themes:
> >> Jewel-Dark-NoFlat-Emphasized-Turquoise-Theme SUCCESS [ 18.421 s]
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Themes:
> >> Jewel-Dark-NoFlat-Emphasized-Violet-Theme FAILURE [ 31.354 s]
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Themes:
> >> Jewel-Dark-NoFlat-Emphasized-Yellow-Theme SKIPPED
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Archetypes
> >> ............... SKIPPED
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Archetypes: Simple
> >> Royale Application SKIPPED
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Archetypes: Simple
> >> Royale Pure-JS Application SKIPPED
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Archetypes: Simple
> >> Royale Pure-SWF Application SKIPPED
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Archetypes: Simple
> >> Royale Library SKIPPED
> >>
> >>     [exec] [INFO] [INFO] Apache Royale: Framework: Archetypes: Simple
> >> Royale Typedef Library 0.9.4 SKIPPED
> >>
> >>     [exec] [INFO] [INFO]
> >> ------------------------------------------------------------------------
> >>
> >>     [exec] [INFO] [INFO] BUILD FAILURE
> >>
> >>     [exec] [INFO] [INFO]
> >> ------------------------------------------------------------------------
> >>
> >>     [exec] [INFO] [INFO] Total time: 38:52 min
> >>
> >>     [exec] [INFO] [INFO] Finished at: 2018-10-04T00:50:41-07:00
> >>
> >>     [exec] [INFO] [INFO]
> >> ------------------------------------------------------------------------
> >>
> >>     [exec] [INFO] [ERROR] Failed to execute goal
> >> org.apache.maven.plugins:maven-deploy-plugin:2.8.2:deploy
> (default-deploy)
> >> on project Jewel-Dark-NoFlat-Emphasized-Violet-Theme: Failed to deploy
> >> artifacts: Could not transfer artifact
> >>
> >>
> org.apache.royale.framework:Jewel-Dark-NoFlat-Emphasized-Violet-Theme:swc.asc:typedefs:0.9.4
> >> from/to apache.releases.https (
> >> https://repository.apache.org/service/local/staging/deploy/maven2):
> >> Connect
> >> to repository.apache.org:443 [repository.apache.org/207.244.88.140]
> >> failed:
> >> Operation timed out (Connection timed out) -> [Help 1]
> >>
> >>     [exec] [INFO] [ERROR]
> >>
> >>     [exec] [INFO] [ERROR] To see the full stack trace of the errors,
> >> re-run Maven with the -e switch.
> >>
> >>     [exec] [INFO] [ERROR] Re-run Maven using the -X switch to enable
> full
> >> debug logging.
> >>
> >>     [exec] [INFO] [ERROR]
> >>
> >>     [exec] [INFO] [ERROR] For more information about the errors and
> >> possible solutions, please read the following articles:
> >>
> >>     [exec] [INFO] [ERROR] [Help 1]
> >> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> >>
> >>     [exec] [INFO] [ERROR]
> >>
> >>     [exec] [INFO] [ERROR] After correcting the problems, you can resume
> >> the build with the command
> >>
> >>     [exec] [INFO] [ERROR]   mvn <goals> -rf
> >> :Jewel-Dark-NoFlat-Emphasized-Violet-Theme
> >>
> >>     [exec] [INFO]
> >> ------------------------------------------------------------------------
> >>
> >> On Wed, Oct 3, 2018 at 2:10 PM OmPrakash Muppirala <
> bigosmallm@gmail.com>
> >> wrote:
> >>
> >>>
> >>>
> >>> On Wed, Oct 3, 2018 at 2:02 PM Alex Harui <aharui@adobe.com.invalid>
> >>> wrote:
> >>>
> >>>> Hi Om,
> >>>>
> >>>> Does anything deploy, or is that the first thing that is attempted to
> >>>> deploy?  I found this article that might help:
> >>>>
> >>>>
> >>
> https://community.apigee.com/questions/50756/unable-to-deploy-using-maven-script-due-to-error-r.html
> >>>
> >>>
> >>> It deployed a lot of artifacts before hitting this error.  I don't see
> >>> anything special with this artifact.  So, I am guessing that it was a
> >>> momentary bad connection that caused this.
> >>>
> >>>
> >>>>
> >>>>
> >>>> I would be concerned about restarting from the middle of a Maven call.
> >> I
> >>>> suppose you could try it, but what if it skipped an artifact?
> >>>>
> >>>
> >>> The maven error message explicitly says this:
> >>>
> >>>     [exec] [INFO] [ERROR] After correcting the problems, you can resume
> >>> the build with the command
> >>>
> >>>     [exec] [INFO] [ERROR]   mvn <goals> -rf
> >>> :Jewel-Light-NoFlat-Primary-Sunflower-Theme
> >>>
> >>>
> >>>>
> >>>> There should be Ant targets for starting only on royale-asjs if
> >>>> royale-compiler and royale=typedefs worked ok.
> >>>>
> >>>> HTH,
> >>>> -Alex
> >>>>
> >>>> On 10/3/18, 11:58 AM, "OmPrakash Muppirala" <bigosmallm@gmail.com>
> >>>> wrote:
> >>>>
> >>>>    Another suggestion I have is - can we do all the pushes to remote
> >>>> after
> >>>>    everything is done locally?  That way, if something goes wrong
> >>>> halfway, we
> >>>>    can just delete the royale-* dirs locally and rerun the
> >>>> releasecandiate ant
> >>>>    script?
> >>>>
> >>>>    Not sure if this is an easy change?
> >>>>
> >>>>    Thanks,
> >>>>    Om
> >>>>
> >>>>    On Wed, Oct 3, 2018 at 11:42 AM OmPrakash Muppirala <
> >>>> bigosmallm@gmail.com>
> >>>>    wrote:
> >>>>
> >>>>> Okay, I tried a couple of times and I have started getting `SSL
> >>>> peer shut
> >>>>> down incorrectly errors`
> >>>>>
> >>>>>     [exec] [INFO] [INFO]
> >>>>>
> >>>>
> ------------------------------------------------------------------------
> >>>>>
> >>>>>     [exec] [INFO] [INFO] BUILD FAILURE
> >>>>>
> >>>>>     [exec] [INFO] [INFO]
> >>>>>
> >>>>
> ------------------------------------------------------------------------
> >>>>>
> >>>>>     [exec] [INFO] [INFO] Total time: 16:04 min
> >>>>>
> >>>>>     [exec] [INFO] [INFO] Finished at: 2018-10-03T11:38:49-07:00
> >>>>>
> >>>>>     [exec] [INFO] [INFO]
> >>>>>
> >>>>
> ------------------------------------------------------------------------
> >>>>>
> >>>>>     [exec] [INFO] [ERROR] Failed to execute goal
> >>>>> org.apache.maven.plugins:maven-deploy-plugin:2.8.2:deploy
> >>>> (default-deploy)
> >>>>> on project Jewel-Light-NoFlat-Primary-Sunflower-Theme: Failed to
> >>>> deploy
> >>>>> artifacts: Could not transfer artifact
> >>>>>
> >>>>
> >>
> org.apache.royale.framework:Jewel-Light-NoFlat-Primary-Sunflower-Theme:swc:0.9.4
> >>>>> from/to apache.releases.https (
> >>>>>
> >>>>
> >>
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Frepository.apache.org%2Fservice%2Flocal%2Fstaging%2Fdeploy%2Fmaven2&amp;data=02%7C01%7Caharui%40adobe.com%7Cf27e84867a5440c6809008d62962338f%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636741899088254161&amp;sdata=vzyO7Stsj3pqyE9Sih32heK62GABKGZo0wlgWpxW0bE%3D&amp;reserved=0
> >>>> ):
> >>>>> Remote host closed connection during handshake: SSL peer shut down
> >>>>> incorrectly -> [Help 1]
> >>>>>
> >>>>>     [exec] [INFO] [ERROR]
> >>>>>
> >>>>>     [exec] [INFO] [ERROR] To see the full stack trace of the
> >>>> errors,
> >>>>> re-run Maven with the -e switch.
> >>>>>
> >>>>>     [exec] [INFO] [ERROR] Re-run Maven using the -X switch to
> >>>> enable
> >>>>> full debug logging.
> >>>>>
> >>>>>     [exec] [INFO] [ERROR]
> >>>>>
> >>>>>     [exec] [INFO] [ERROR] For more information about the errors
> >> and
> >>>>> possible solutions, please read the following articles:
> >>>>>
> >>>>>     [exec] [INFO] [ERROR] [Help 1]
> >>>>>
> >>>>
> >>
> https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fcwiki.apache.org%2Fconfluence%2Fdisplay%2FMAVEN%2FMojoExecutionException&amp;data=02%7C01%7Caharui%40adobe.com%7Cf27e84867a5440c6809008d62962338f%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636741899088254161&amp;sdata=RU7b9uJt%2FtsXJiX376HgIqRTvKoiKZcs7Z%2Flr1b4wO8%3D&amp;reserved=0
> >>>>>
> >>>>>     [exec] [INFO] [ERROR]
> >>>>>
> >>>>>     [exec] [INFO] [ERROR] After correcting the problems, you can
> >>>> resume
> >>>>> the build with the command
> >>>>>
> >>>>>     [exec] [INFO] [ERROR]   mvn <goals> -rf
> >>>>> :Jewel-Light-NoFlat-Primary-Sunflower-Theme
> >>>>>
> >>>>>     [exec] [INFO]
> >>>>>
> >>>>
> ------------------------------------------------------------------------
> >>>>>
> >>>>>
> >>>>> I am guessing it is a bad internet connection.  I am wondering if
> >>>> we can
> >>>>> pass a -rf (resume from) option to the maven call from ant?
> >>>> Otherwise
> >>>>> doing all this from scratch everytime is a big pain.
> >>>>>
> >>>>> Thanks,
> >>>>> Om
> >>>>>
> >>>>> On Wed, Oct 3, 2018 at 12:47 AM Alex Harui
> >> <aharui@adobe.com.invalid
> >>>>>
> >>>>> wrote:
> >>>>>
> >>>>>> Looks like it was a missing [
> >>>>>>
> >>>>>> MXRoyale and SparkRoyale built for me.
> >>>>>>
> >>>>>> HTH,
> >>>>>> -Alex
> >>>>>>
> >>>>>> On 10/3/18, 12:43 AM, "OmPrakash Muppirala" <
> >> bigosmallm@gmail.com>
> >>>>>> wrote:
> >>>>>>
> >>>>>>    Thanks!
> >>>>>>
> >>>>>>    I reverted everything back to previous state.  I can give it
> >> a
> >>>> shot
> >>>>>>    tomorrow evening.
> >>>>>>
> >>>>>>    Regards,
> >>>>>>    Om
> >>>>>>
> >>>>>>    On Wed, Oct 3, 2018 at 12:41 AM Alex Harui
> >>>> <aharui@adobe.com.invalid>
> >>>>>> wrote:
> >>>>>>
> >>>>>>> It was in a releasable state.  TourDeFlex was running on
> >> it.
> >>>>>>>
> >>>>>>> I'm trying to track down the change that broke it.
> >>>>>>>
> >>>>>>> -Alex
> >>>>>>>
> >>>>>>> On 10/3/18, 12:32 AM, "OmPrakash Muppirala" <
> >>>> bigosmallm@gmail.com>
> >>>>>> wrote:
> >>>>>>>
> >>>>>>>    A bit more progress. Now we are failing on the MXRoyale
> >>>> project:
> >>>>>>>
> >>>>>>>         [exec] [INFO] [INFO]
> >>>>>>>
> >>>>>>>
> >>>>>>
> >>>>
> ------------------------------------------------------------------------
> >>>>>>>
> >>>>>>>         [exec] [INFO] [INFO] BUILD FAILURE
> >>>>>>>
> >>>>>>>         [exec] [INFO] [INFO]
> >>>>>>>
> >>>>>>>
> >>>>>>
> >>>>
> ------------------------------------------------------------------------
> >>>>>>>
> >>>>>>>         [exec] [INFO] [INFO] Total time: 01:34 min
> >>>>>>>
> >>>>>>>         [exec] [INFO] [INFO] Finished at:
> >>>> 2018-10-03T00:28:14-07:00
> >>>>>>>
> >>>>>>>         [exec] [INFO] [INFO]
> >>>>>>>
> >>>>>>>
> >>>>>>
> >>>>
> ------------------------------------------------------------------------
> >>>>>>>
> >>>>>>>         [exec] [INFO] [ERROR] Failed to execute goal
> >>>>>>>
> >>>> org.apache.royale.compiler:royale-maven-plugin:0.9.4:compile-as
> >>>>>>>    (default-compile-as) on project MXRoyale: There were
> >>>> errors
> >>>>>> during the
> >>>>>>>    build. Got return code 3 -> [Help 1]
> >>>>>>>
> >>>>>>>         [exec] [INFO] [ERROR]
> >>>>>>>
> >>>>>>>         [exec] [INFO] [ERROR] To see the full stack trace
> >>>> of the
> >>>>>> errors,
> >>>>>>>    re-run Maven with the -e switch.
> >>>>>>>
> >>>>>>>         [exec] [INFO] [ERROR] Re-run Maven using the -X
> >>>> switch to
> >>>>>> enable
> >>>>>>> full
> >>>>>>>    debug logging.
> >>>>>>>
> >>>>>>>         [exec] [INFO] [ERROR]
> >>>>>>>
> >>>>>>>         [exec] [INFO] [ERROR] For more information about
> >> the
> >>>>>> errors and
> >>>>>>>    possible solutions, please read the following articles:
> >>>>>>>
> >>>>>>>         [exec] [INFO] [ERROR] [Help 1]
> >>>>>>>
> >>>>>>>
> >>>>>>
> >>>>
> >>
> https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fcwiki.apache.org%2Fconfluence%2Fdisplay%2FMAVEN%2FMojoExecutionException&amp;data=02%7C01%7Caharui%40adobe.com%7Cf27e84867a5440c6809008d62962338f%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636741899088254161&amp;sdata=RU7b9uJt%2FtsXJiX376HgIqRTvKoiKZcs7Z%2Flr1b4wO8%3D&amp;reserved=0
> >>>>>>>
> >>>>>>>         [exec] [INFO] [ERROR]
> >>>>>>>
> >>>>>>>         [exec] [INFO] [ERROR] After correcting the
> >>>> problems, you
> >>>>>> can
> >>>>>>> resume
> >>>>>>>    the build with the command
> >>>>>>>
> >>>>>>>         [exec] [INFO] [ERROR]   mvn <goals> -rf :MXRoyale
> >>>>>>>
> >>>>>>>
> >>>>>>>    Can we perhaps turn this project off?  Is it in a
> >>>> releasable
> >>>>>> state?
> >>>>>>>
> >>>>>>>    On Tue, Oct 2, 2018 at 7:30 PM OmPrakash Muppirala <
> >>>>>>> bigosmallm@gmail.com>
> >>>>>>>    wrote:
> >>>>>>>
> >>>>>>>> I'm going to give this another shot in a couple of
> >>>> hours,
> >>>>>> unless
> >>>>>>> there are
> >>>>>>>> any objections.
> >>>>>>>>
> >>>>>>>> Thanks,
> >>>>>>>> Om
> >>>>>>>>
> >>>>>>>> On Mon, Oct 1, 2018, 2:04 PM Alex Harui
> >>>>>> <aharui@adobe.com.invalid>
> >>>>>>> wrote:
> >>>>>>>>
> >>>>>>>>> Jewel is mentioned in there.  I added mention of the
> >>>>>> migration
> >>>>>>> components
> >>>>>>>>> and tour de flex.  Not sure if I got the formatting
> >>>> right.
> >>>>>> I think
> >>>>>>> it is
> >>>>>>>>> good enough.
> >>>>>>>>>
> >>>>>>>>> -Alex
> >>>>>>>>>
> >>>>>>>>> On 10/1/18, 12:13 PM, "OmPrakash Muppirala" <
> >>>>>> bigosmallm@gmail.com>
> >>>>>>>>> wrote:
> >>>>>>>>>
> >>>>>>>>>    I updated it, although it looks a bit sparse
> >>>> now.  Can
> >>>>>> we list
> >>>>>>> a few
> >>>>>>>>> major
> >>>>>>>>>    highlights here, that I can go add to the
> >> release
> >>>> notes?
> >>>>>>>>>    Jewel should at least have several updates.
> >>>>>>>>>
> >>>>>>>>>    Thanks,
> >>>>>>>>>    Om
> >>>>>>>>>
> >>>>>>>>>    On Mon, Oct 1, 2018 at 12:09 PM Alex Harui
> >>>>>>> <aharui@adobe.com.invalid>
> >>>>>>>>> wrote:
> >>>>>>>>>
> >>>>>>>>>> Hey, I just noticed that nobody put a 0.9.4
> >>>> section in
> >>>>>> the
> >>>>>>>>> RELEASE_NOTES.
> >>>>>>>>>> Maybe just rename the 0.9.3 section?
> >>>>>>>>>>
> >>>>>>>>>> -Alex
> >>>>>>>>>>
> >>>>>>>>>> On 10/1/18, 12:07 PM, "OmPrakash Muppirala" <
> >>>>>>> bigosmallm@gmail.com>
> >>>>>>>>> wrote:
> >>>>>>>>>>
> >>>>>>>>>>    Good catch!  I just pushed a fix for that.
> >>>>>>>>>>
> >>>>>>>>>>    Thanks,
> >>>>>>>>>>    Om
> >>>>>>>>>>
> >>>>>>>>>>    On Mon, Oct 1, 2018 at 11:04 AM Alex Harui
> >>>>>>>>> <aharui@adobe.com.invalid>
> >>>>>>>>>> wrote:
> >>>>>>>>>>
> >>>>>>>>>>> Om,
> >>>>>>>>>>>
> >>>>>>>>>>> I think the <tag>release/0.9.4</tag> in
> >>>>>>> royale-asjs/pom.xml
> >>>>>>>>> needs to
> >>>>>>>>>> be
> >>>>>>>>>>> reverted back to 0.9.3.
> >>>>>>>>>>>
> >>>>>>>>>>> Everything else looks ok from my quick
> >>>>>> examination.
> >>>>>>>>>>>
> >>>>>>>>>>> Thanks and good luck,
> >>>>>>>>>>> -Alex
> >>>>>>>>>>>
> >>>>>>>>>>> On 10/1/18, 10:29 AM, "Piotr Zarzycki" <
> >>>>>>>>> piotrzarzycki21@gmail.com>
> >>>>>>>>>> wrote:
> >>>>>>>>>>>
> >>>>>>>>>>>    I saw your commit and I think you
> >>>> should be
> >>>>>> ok.
> >>>>>>>>>>>
> >>>>>>>>>>>    pon., 1 paź 2018 o 19:21 OmPrakash
> >>>> Muppirala
> >>>>>> <
> >>>>>>>>>> bigosmallm@gmail.com>
> >>>>>>>>>>>    napisał(a):
> >>>>>>>>>>>
> >>>>>>>>>>>> Okay, I did the following to
> >> reset:
> >>>>>>>>>>>>
> >>>>>>>>>>>> For all three repos:
> >>>>>>>>>>>> * Reverted all references of 0.9.5
> >>>> to 0.9.4
> >>>>>>>>>>>> * Deleted 0.9.4-rc1 tag
> >>>>>>>>>>>> * Deleted branch: release/0.9.4
> >>>>>>>>>>>>
> >>>>>>>>>>>> Can someone please make sure that
> >>>> we are
> >>>>>> good
> >>>>>>> before
> >>>>>>>>> starting
> >>>>>>>>>> work?
> >>>>>>>>>>>>
> >>>>>>>>>>>> Thanks,
> >>>>>>>>>>>> Om
> >>>>>>>>>>>>
> >>>>>>>>>>>> On Mon, Oct 1, 2018 at 1:51 AM
> >>>> Carlos
> >>>>>> Rovira <
> >>>>>>>>>>> carlosrovira@apache.org>
> >>>>>>>>>>>> wrote:
> >>>>>>>>>>>>
> >>>>>>>>>>>>> Hi Om,
> >>>>>>>>>>>>> is related to flash player
> >>>> debugger not
> >>>>>>> launched? are
> >>>>>>>>> you on
> >>>>>>>>>> Mac?
> >>>>>>>>>>>>> I think on Mac I have to make
> >>>> *.swf
> >>>>>> files be
> >>>>>>> always
> >>>>>>>>> opened
> >>>>>>>>>> by Flash
> >>>>>>>>>>>> Player
> >>>>>>>>>>>>> debugger.
> >>>>>>>>>>>>>
> >>>>>>>>>>>>> In the other hand, I need to
> >>>> commit
> >>>>>> during the
> >>>>>>> day
> >>>>>>>>> some
> >>>>>>>>>> fixes, one
> >>>>>>>>>>> on
> >>>>>>>>>>>>> typedefs and expect more on
> >>>> compiler. So
> >>>>>> if you
> >>>>>>> plan
> >>>>>>>>> to try
> >>>>>>>>>> again
> >>>>>>>>>>> some
> >>>>>>>>>>>>> hours ago, please, remove the
> >>>> commits to
> >>>>>> left
> >>>>>>> the
> >>>>>>>>> repos so
> >>>>>>>>>> we can
> >>>>>>>>>>> commit
> >>>>>>>>>>>>> new work
> >>>>>>>>>>>>>
> >>>>>>>>>>>>> thanks!
> >>>>>>>>>>>>>
> >>>>>>>>>>>>> Carlos
> >>>>>>>>>>>>>
> >>>>>>>>>>>>>
> >>>>>>>>>>>>>
> >>>>>>>>>>>>>
> >>>>>>>>>>>>>
> >>>>>>>>>>>>> El lun., 1 oct. 2018 a las
> >> 10:29,
> >>>>>> OmPrakash
> >>>>>>> Muppirala
> >>>>>>>>> (<
> >>>>>>>>>>>>> bigosmallm@gmail.com>)
> >>>>>>>>>>>>> escribió:
> >>>>>>>>>>>>>
> >>>>>>>>>>>>>> I provided path to Chrome via
> >>>>>> -Dbrowser, but
> >>>>>>> I got
> >>>>>>>>> an
> >>>>>>>>>> error that
> >>>>>>>>>>> ant
> >>>>>>>>>>>> was
> >>>>>>>>>>>>>> not able to access the
> >>>> application.
> >>>>>>>>>>>>>> So, I tried installing firefox
> >>>> and that
> >>>>>>> seemed to
> >>>>>>>>> work.
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>>> On Mon, Oct 1, 2018 at 1:26 AM
> >>>> Piotr
> >>>>>> Zarzycki
> >>>>>>> <
> >>>>>>>>>>>> piotrzarzycki21@gmail.com
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>>> wrote:
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>>>> Hi Om,
> >>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>> You did use Firefox for that
> >>>> purpose
> >>>>>> ? I
> >>>>>>> had to
> >>>>>>>>> specify
> >>>>>>>>>>>> -Dbrowser=path
> >>>>>>>>>>>>> to
> >>>>>>>>>>>>>>> firefox.exe
> >>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>> Thanks,
> >>>>>>>>>>>>>>> Piotr
> >>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>> pon., 1 paź 2018 o 10:22
> >>>> OmPrakash
> >>>>>>> Muppirala <
> >>>>>>>>>>> bigosmallm@gmail.com>
> >>>>>>>>>>>>>>> napisał(a):
> >>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>> Okay, I made several
> >>>> attempts
> >>>>>> through the
> >>>>>>> day,
> >>>>>>>>> making
> >>>>>>>>>>> progress each
> >>>>>>>>>>>>>> time.
> >>>>>>>>>>>>>>>> The last run failed
> >>>> because the
> >>>>>> browser
> >>>>>>> could
> >>>>>>>>> not be
> >>>>>>>>>>> launched.
> >>>>>>>>>>>>>>>> I am going to pause on
> >> this
> >>>> and
> >>>>>> try again
> >>>>>>>>> tomorrow (or
> >>>>>>>>>>> later) . If
> >>>>>>>>>>>>>>> someone
> >>>>>>>>>>>>>>>> else wants to give this a
> >>>> go in the
> >>>>>>> meantimne,
> >>>>>>>>> they are
> >>>>>>>>>>> welcome :-)
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>> Thanks,
> >>>>>>>>>>>>>>>> Om
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>> On Mon, Oct 1, 2018 at
> >>>> 12:22 AM
> >>>>>> Carlos
> >>>>>>> Rovira <
> >>>>>>>>>>>>> carlosrovira@apache.org
> >>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>> wrote:
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>> Hi Om,
> >>>>>>>>>>>>>>>>> no,  I Thought this was
> >>>> due to
> >>>>>> different
> >>>>>>>>> tries of the
> >>>>>>>>>>> release
> >>>>>>>>>>>>> process
> >>>>>>>>>>>>>>> but
> >>>>>>>>>>>>>>>>> most of the poms are in
> >>>>>> 0.9.6-SNAPSHOT.
> >>>>>>>>>>>>>>>>> You can search the
> >> entire
> >>>> repo
> >>>>>> for
> >>>>>>>>> "0.9.X-SNAPSHOT"
> >>>>>>>>>> string
> >>>>>>>>>>> to see
> >>>>>>>>>>>>>> that
> >>>>>>>>>>>>>>>> now
> >>>>>>>>>>>>>>>>> X is 6.
> >>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>> thanks
> >>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>> El lun., 1 oct. 2018 a
> >>>> las 2:07,
> >>>>>>> OmPrakash
> >>>>>>>>> Muppirala
> >>>>>>>>>> (<
> >>>>>>>>>>>>>>>>> bigosmallm@gmail.com>)
> >>>>>>>>>>>>>>>>> escribió:
> >>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>> On Sun, Sep 30, 2018,
> >>>> 2:13 PM
> >>>>>> Carlos
> >>>>>>> Rovira
> >>>>>>>>> <
> >>>>>>>>>>>>>> carlosrovira@apache.org
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>> wrote:
> >>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>> Hi Om,
> >>>>>>>>>>>>>>>>>>> just saw that some
> >>>> poms was
> >>>>>> not
> >>>>>>> changed to
> >>>>>>>>>>> 0.9.6-SNAPSHOT.
> >>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>> Do you mean
> >>>> 0.9.4-SNAPSHOT?
> >>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>> Thanks,
> >>>>>>>>>>>>>>>>>> Om
> >>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>> I think that should be
> >>>> fixed
> >>>>>> and get a
> >>>>>>>>> prepare
> >>>>>>>>>> maven
> >>>>>>>>>>> release
> >>>>>>>>>>>>>> process
> >>>>>>>>>>>>>>>> that
> >>>>>>>>>>>>>>>>>>> could finaly gets
> >> all
> >>>> poms
> >>>>>> updated
> >>>>>>> to new
> >>>>>>>>>> version.
> >>>>>>>>>>>>>>>>>>> Don't know if that
> >>>> could be
> >>>>>> the
> >>>>>>> problem.
> >>>>>>>>> Can you
> >>>>>>>>>> try
> >>>>>>>>>>> again?
> >>>>>>>>>>>>>>>>>>> thanks
> >>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>> El dom., 30 sept.
> >>>> 2018 a las
> >>>>>> 21:32,
> >>>>>>>>> OmPrakash
> >>>>>>>>>>> Muppirala (<
> >>>>>>>>>>>>>>>>>>>
> >> bigosmallm@gmail.com
> >>>>> )
> >>>>>> escribió:
> >>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>> Made a bit more
> >>>> progress,
> >>>>>> but the
> >>>>>>> build
> >>>>>>>>> is
> >>>>>>>>>> failing
> >>>>>>>>>>> here
> >>>>>>>>>>>> now:
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [INFO]
> >>>>>> Apache
> >>>>>>> Royale:
> >>>>>>>>>> Examples:
> >>>>>>>>>>> Royale:
> >>>>>>>>>>>>>>>>>>>>
> >>>> DataBindingExample_as
> >>>>>> SUCCESS [
> >>>>>>> 2.469
> >>>>>>>>> s]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [INFO]
> >>>>>> Apache
> >>>>>>> Royale:
> >>>>>>>>>> Examples:
> >>>>>>>>>>> Royale:
> >>>>>>>>>>>>>>>>>>>>
> >>>> DataBindingExample_Flat
> >>>>>> FAILURE [
> >>>>>>>>> 1.756 s]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [INFO]
> >>>>>> Apache
> >>>>>>> Royale:
> >>>>>>>>>> Examples:
> >>>>>>>>>>> Royale:
> >>>>>>>>>>>>>>>>>>>>
> >>>>>> DataBindingExampleWithLayout
> >>>>>>> SKIPPED
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [INFO]
> >>>>>> Apache
> >>>>>>> Royale:
> >>>>>>>>>> Examples:
> >>>>>>>>>>> Royale:
> >>>>>>>>>>>>>>>>>>> DataGridExample
> >>>>>>>>>>>>>>>>>>>> ... SKIPPED
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>> Detailed error:
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>    [exec] [INFO]
> >>>> [INFO]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>
> >>>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>
> >>>>>>>
> >>>>>>
> >>>>
> ------------------------------------------------------------------------
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [INFO]
> >>>>>> BUILD
> >>>>>>> FAILURE
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [INFO]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>
> >>>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>
> >>>>>>>
> >>>>>>
> >>>>
> ------------------------------------------------------------------------
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [INFO]
> >>>>>> Total
> >>>>>>> time:
> >>>>>>>>> 07:03 min
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [INFO]
> >>>>>>> Finished at:
> >>>>>>>>>>>>>> 2018-09-30T12:17:45-07:00
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [INFO]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>
> >>>>>>>>>>>>
> >>>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>
> >>>>>>>
> >>>>>>
> >>>>
> ------------------------------------------------------------------------
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>> Failed
> >>>>>>> to
> >>>>>>>>> execute
> >>>>>>>>>> goal
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>
> >>>>>>>>>
> >>>> org.apache.maven.plugins:maven-dependency-plugin:2.10:unpack
> >>>>>>>>>>>>>>>>>>> (unpack-fonts)
> >>>>>>>>>>>>>>>>>>>> on project
> >>>>>>> DataBindingExample_Flat:
> >>>>>>>>> Unable to
> >>>>>>>>>> find
> >>>>>>>>>>>> artifact.
> >>>>>>>>>>>>>>> Could
> >>>>>>>>>>>>>>>>> not
> >>>>>>>>>>>>>>>>>>> find
> >>>>>>>>>>>>>>>>>>>> artifact
> >>>>>>>>>> org.apache.royale.framework:Fonts:war:0.9.4
> >>>>>>>>>>> in
> >>>>>>>>>>>>>>>>> apache-release
> >>>>>>>>>>>>>>>>>> (
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>
> >>>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>
> >>>>>>>
> >>>>>>
> >>>>
> >>
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Frepository.apache.org%2Fcontent%2Frepositories%2Freleases&amp;data=02%7C01%7Caharui%40adobe.com%7Cf27e84867a5440c6809008d62962338f%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636741899088264171&amp;sdata=UWRtC77ZPXzIU44fNnW0rzkzIeHwzHAuQP0SqTIQkog%3D&amp;reserved=0
> >>>>>>>>>>> )
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>> Try
> >>>>>>>>> downloading the
> >>>>>>>>>> file
> >>>>>>>>>>>> manually
> >>>>>>>>>>>>>> from
> >>>>>>>>>>>>>>>> the
> >>>>>>>>>>>>>>>>>>>> project website.
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>> Then,
> >>>>>>>>> install it
> >>>>>>>>>> using the
> >>>>>>>>>>>>> command:
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>>>> [ERROR]     mvn
> >>>>>>>>>>> install:install-file
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>> -DgroupId=org.apache.royale.framework
> >>>>>>>>>>> -DartifactId=Fonts
> >>>>>>>>>>>>>>>>>> -Dversion=0.9.4
> >>>>>>>>>>>>>>>>>>>> -Dpackaging=war
> >>>>>>> -Dfile=/path/to/file
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>>>>> Alternatively, if
> >>>>>>>>>> you
> >>>>>>>>>>> host your
> >>>>>>>>>>>>> own
> >>>>>>>>>>>>>>>>>> repository
> >>>>>>>>>>>>>>>>>>>> you can deploy the
> >>>> file
> >>>>>> there:
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>>>> [ERROR]     mvn
> >>>>>>>>>> deploy:deploy-file
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>> -DgroupId=org.apache.royale.framework
> >>>>>>>>>>> -DartifactId=Fonts
> >>>>>>>>>>>>>>>>>> -Dversion=0.9.4
> >>>>>>>>>>>>>>>>>>>> -Dpackaging=war
> >>>>>>> -Dfile=/path/to/file
> >>>>>>>>>> -Durl=[url]
> >>>>>>>>>>>>>>>> -DrepositoryId=[id]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>>>>>>>>>>>>>>
> >>>>>>> org.apache.royale.framework:Fonts:war:0.9.4
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>> from
> >>>>>>> the
> >>>>>>>>> specified
> >>>>>>>>>> remote
> >>>>>>>>>>>>>>> repositories:
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>>>>>>>>>     [exec] [INFO]
> >>>> [ERROR]
> >>>>>>>>> apache-release (
> >>>>>>>>>>>>>>>>>>>>
> >>>>>>>>>>>>
> >>>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>
> >>>>>>>
> >>>
>
>

-- 
Carlos Rovira
http://about.me/carlosrovira

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message