royale-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Piotr Zarzycki <piotrzarzyck...@gmail.com>
Subject Re: Difficulties with using in project JS version of Royale swc
Date Tue, 11 Sep 2018 16:09:22 GMT
Alex,

It looks like library.swf contains in both cases required information and
files. I have in this library two files.

1) MyClass -> Contains import of all classes
2) MyViewClass - contains function in blocs COMPILE::SWF and COMPILE::JS

JS library dump: https://paste.apache.org/dLA2
SWF library dump: https://paste.apache.org/o1rW

Next step is to try using -js-library-path etc to check whether it makes
any difference.

Thanks,
Piotr


wt., 11 wrz 2018 o 18:00 Piotr Zarzycki <piotrzarzycki21@gmail.com>
napisał(a):

> Yes I did it. Both looks almost the same.
>
> JS -> https://paste.apache.org/XhLi
> SWF -> https://paste.apache.org/MwKB
>
> I will provide in couple of minutes SWF dump.
>
> Thanks,
> Piotr
>
> wt., 11 wrz 2018 o 17:52 Alex Harui <aharui@adobe.com.invalid> napisał(a):
>
>> Royale SWCs should always have a folder of JS files unless they are SWF
>> only.
>>
>> Before you dump the library.swf, did you look in the catalog.xml?  It is
>> easier to see what it thinks is in the SWC.  It could be that the manifest
>> or other list of classes is not specified in the JS compile.
>>
>> HTH,
>> -Alex
>>
>> On 9/11/18, 8:49 AM, "piotrz" <piotrz@apache.org> wrote:
>>
>>     Hi Alex,
>>
>>     The first part of your answer is behind me. I have checked what is
>> inside
>>     both swcs. On the left sight of the screenshot is JS version.
>>
>>     <
>> https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-royale-development.20373.n8.nabble.com%2Ffile%2Ft1%2Fjs_swf.png&amp;data=02%7C01%7Caharui%40adobe.com%7C433e8a0206c14a29f6de08d617fe3860%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636722777968242370&amp;sdata=P6cfNMW8dyfFqNHlIrvlpLYbRdDsK5KLzz7QuLADZKQ%3D&amp;reserved=0>
>>
>>
>>     Interesting thing is that in both cases I have folder with JS files.
>>
>>     I have definitely my swcs in library-path, because SWF version is
>> working
>>     fine.
>>
>>     I will try to examine library.swf and get back to you.
>>
>>     Thanks,
>>     Piotr
>>
>>
>>
>>     --
>>     Sent from:
>> https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-royale-development.20373.n8.nabble.com%2F&amp;data=02%7C01%7Caharui%40adobe.com%7C433e8a0206c14a29f6de08d617fe3860%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636722777968242370&amp;sdata=mx1qBKZd81wM0BuMJgh7dWAr3dc%2FdGQLuKHphalMqRo%3D&amp;reserved=0
>>
>>
>>
>
> --
>
> Piotr Zarzycki
>
> Patreon: *https://www.patreon.com/piotrzarzycki
> <https://www.patreon.com/piotrzarzycki>*
>


-- 

Piotr Zarzycki

Patreon: *https://www.patreon.com/piotrzarzycki
<https://www.patreon.com/piotrzarzycki>*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message