royale-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harbs <harbs.li...@gmail.com>
Subject Re: 0.9.3 Release
Date Thu, 17 May 2018 11:33:16 GMT
I see the following in the pom:
    <dependency>
      <groupId>org.apache.royale.framework</groupId>
      <artifactId>Jewel-Light-NoFlat-Primary-Blue-Theme</artifactId>
      <version>0.9.4-SNAPSHOT</version>
      <type>swc</type>
      <scope>theme</scope>
      <classifier>js</classifier>
    </dependency>

It looks like there’s no default theme for Jewel. Should that be fixed?

How are themes specified to the compiler?

> On May 17, 2018, at 2:26 PM, Harbs <harbs.lists@gmail.com> wrote:
> 
> Oh. I guess that’s why the styling did not work.
> 
> Carlos, what compiler options are needed for Jewel?
> 
> Harbs
> 
>> On May 17, 2018, at 2:23 PM, Piotr Zarzycki <piotrzarzycki21@gmail.com> wrote:
>> 
>> This is another issue. You cannot build those examples using IDE. I think
>> we should raise on GitHub. I also cannot build those examples in Moonshine.
>> Something needs to be configured. Probably some additional args for
>> compiler related to theme etc.
>> 
>> 2018-05-17 13:18 GMT+02:00 Harbs <harbs.lists@gmail.com>:
>> 
>>> VSCode using asconfigc
>>> 
>>>> On May 17, 2018, at 12:57 PM, Piotr Zarzycki <piotrzarzycki21@gmail.com>
>>> wrote:
>>>> 
>>>> Harbs,
>>>> 
>>>> How did you build the examples? Using VSCode or script ant/maven ?
>>>> 
>>>> Thanks,
>>>> Piotr
>>>> 
>>>> 2018-05-17 11:55 GMT+02:00 Harbs <harbs.lists@gmail.com <mailto:
>>> harbs.lists@gmail.com>>:
>>>> 
>>>>> FWIW, it looks to me like the only thing that will not work in the blog
>>>>> post is <j:View> needs to be <js:View> and <j:TextPrompt>
needs to be
>>>>> <js:TextPromptBead>
>>>>> 
>>>>> Although when I compile styles are definitely missing.
>>>>> 
>>>>> Yeah. Jewel is definitely missing important pieces… :-(
>>>>> 
>>>>> Harbs
>>>>> 
>>>>>> On May 17, 2018, at 12:40 PM, Harbs <harbs.lists@gmail.com>
wrote:
>>>>>> 
>>>>>> You are right. I missed this.
>>>>>> 
>>>>>> What is the minimum change necessary to get this to work?
>>>>>> 
>>>>>>> On May 17, 2018, at 12:24 PM, Carlos Rovira <carlosrovira@apache.org
>>>>> <mailto:carlosrovira@apache.org <mailto:carlosrovira@apache.org>>>
>>> wrote:
>>>>>>> 
>>>>>>> I think you missed one important point I
>>>>>>> posted in other email: All blog post samples posted that are
using the
>>>>>>> actual names, packages and namespaces. If you release 0.9.3 without
>>> all
>>>>>>> that, we can destroy out credibility since in all posts we have:
>>>>>>> 
>>>>>>> "The example uses the new Jewel UI set that supports themes.
Jewel
>>> will
>>>>> be
>>>>>>> available in the forthcoming 0.9.3 release of Royale. In the
meanwhile
>>>>> you
>>>>>>> can find it in the develop branch."
>>>>>>> 
>>>>>>> and the code is tailored with the actual api.
>>>>>>> 
>>>>>>> For that reason, I think is important to hold 0.9.3 until it
can ship
>>>>> with
>>>>>>> all that we are promising in website and social networks for
the
>>> latest
>>>>> 2
>>>>>>> months. I think this is crucial.
>>>>>> 
>>>>> 
>>>>> 
>>>> 
>>>> 
>>>> --
>>>> 
>>>> Piotr Zarzycki
>>>> 
>>>> Patreon: *https://www.patreon.com/piotrzarzycki <
>>> https://www.patreon.com/piotrzarzycki>
>>>> <https://www.patreon.com/piotrzarzycki <https://www.patreon.com/
>>> piotrzarzycki>>*
>>> 
>>> 
>> 
>> 
>> -- 
>> 
>> Piotr Zarzycki
>> 
>> Patreon: *https://www.patreon.com/piotrzarzycki
>> <https://www.patreon.com/piotrzarzycki>*
> 


Mime
View raw message