royale-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com.INVALID>
Subject Re: Can't get ClassReference work on themes
Date Fri, 16 Mar 2018 15:39:43 GMT
Hi Carlos,

On a good night, I've closed up the computer and am heading off to sleep
about 15 minutes before this showed up in my inbox.  Although there are
weekends like last weekend when I have to shut down about an hour earlier
than that.

You should be able to follow the commits to see what changes I made to the
compiler, the swcs and the example.

The compiler changed to include theme swcs when searching for classes to
resolve ClassReference.  We've had problems in the past with you picking
up changes to the compiler, so I strongly recommend that you learn how to
inject System.out.printlns in the compiler so you can first prove that you
have picked up the changes before asking for help.  Given our work
schedules it will be way more efficient if you can verify that
independently.

The SWCs changed to not include blue.css and red.css in the SWC.  But
also, I changed the JewelTheme.swc to build both SWF and JSRoyale targets
in order to have a FontInject.js.  Any <inject_html> is pulled from the
transpiled js file, not the AS source.

Then the example was changed to list JewelTheme and blue.css.

The above was all done in Ant because I wanted to get your feedback on
refactoring in Maven.

HTH,
-Alex

On 3/16/18, 12:47 AM, "carlos.rovira@gmail.com on behalf of Carlos Rovira"
<carlos.rovira@gmail.com on behalf of carlosrovira@apache.org> wrote:

>Hi Alex,
>
>I'll be here in an hour or so,
>
>for this issue, I'll only need to know what's the problem that you
>addressed in ANT and that I should fix in Maven
>I revised the ANT yesterday and I still don't know why JewelExample
>continues throwing the error that don't find definitions in theme.
>
>I think this is important in order to close structure problems and begin
>styling work. I want to reach AFAIC to left behind Arquitecture and
>structure problems and start only design work on Jewel, but I need to get
>ViewBeads on themes (and other classes on themes)
>
>If you can't see this, I'll try it myself, but the problem is that I'm
>still don't understand what's the problem, at least if you know what's in
>build.xml that isn't in pom.xml it will help to focus the problem to try
>to
>solve it.
>
>Thanks for your support
>
>2018-03-15 23:55 GMT+01:00 Carlos Rovira <carlosrovira@apache.org>:
>
>> Hi,
>>
>> I uploaded some Changes to try to use a LabelViewBead
>> I think I have the swc theme compiled right, but JewelExample continues
>> without see the LabelViewBead
>>
>> Can someone take a look and let me know what is wrong in pom.xml to make
>> JewelExample compiles ok?
>>
>> I'll close for today, if you let me know some solution I'll try It in
>>7-8
>> hours
>>
>> thanks in advance
>>
>> --
>> Carlos Rovira
>> 
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fabout.me%
>>2Fcarlosrovira&data=02%7C01%7Caharui%40adobe.com%7C51a1100f23d3405eee6608
>>d58b1247cc%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C63656783299337487
>>2&sdata=Jn7PSmEnE%2BZxyCV1DlQXvb9BvqMBS%2F1DebSSAa616G4%3D&reserved=0
>>
>>
>
>
>-- 
>Carlos Rovira
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fabout.me%2
>Fcarlosrovira&data=02%7C01%7Caharui%40adobe.com%7C51a1100f23d3405eee6608d5
>8b1247cc%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636567832993374872&s
>data=Jn7PSmEnE%2BZxyCV1DlQXvb9BvqMBS%2F1DebSSAa616G4%3D&reserved=0

Mime
View raw message