royale-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Rovira <carlosrov...@apache.org>
Subject Re: system requirements for Royale
Date Tue, 30 Jan 2018 10:37:20 GMT
Hi,

someone with the time and a clean virtual machine could test this to see if
is or not needed
thanks Andrew for pointing this



2018-01-30 7:06 GMT+01:00 Alex Harui <aharui@adobe.com.invalid>:

> Good questions.  I don't know for sure about the JDK.  Do you have a JDK
> or just a JRE?  If you just have a JRE, does Royale compile your code?
> I've always had JDKs on my system so it would be better if someone who
> never had a JDK on their system tried it.
>
> I checked the Adobe docs and don't see any requirement for a JDK.  I have
> seen a few Java apps require a JDK.  I doubt we require it though.
>
> Regarding Unix/Linux, I don't think anybody has done serious testing.
>
> Regarding minimum Mac or PC requirements, I think the Java 1.7 requirement
> will set the baseline.
>
> HTH,
> -Alex
>
> On 1/29/18, 10:47 AM, "Andrew Wetmore" <cottage14@gmail.com> wrote:
>
> >In the README I, um, read:
> >
> >Royale requires Java SDK 1.7 or greater to be installed on your computer.
> >
> >Is that true even if you are using the compiled binaries and not building
> >Royale?
> >
> >For the help docs, are there any other system requirements, if we are
> >presuming a modern Mac or PC machine? Does Royale run on a Unix box?
> >
> >--
> >Andrew Wetmore
> >
> >https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fcottage14
> .
> >blogspot.com%2F&data=02%7C01%7Caharui%40adobe.com%
> 7Cc20890d0159047cda40a08
> >d56748cb1b%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%
> 7C636528484705179817
> >&sdata=pse5cGtfbH0udKRo4%2Bor6HzJytL5b04hUuLBUclT8XU%3D&reserved=0
>
>


-- 
Carlos Rovira
http://about.me/carlosrovira

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message