royale-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com.INVALID>
Subject Re: Apache Royale 0.9 setup
Date Sat, 28 Oct 2017 06:56:50 GMT
Hmm.  Not sure why code-assist isn't working.  Looking into it...

-Alex

On 10/26/17, 4:25 PM, "Idylog - Nicolas Granon" <ngranon@idylog.com> wrote:

>Many thanks for your answer.
>
>
>We have done what you suggest and :
>Previous errors do not show any more (that is good !)
>
>Auto-completion still doesn't not work *at all* (implies that "import"
>directives are not generated and we cannot compile since of course all
>interfaces, type definition etc. cannot be found). (and that is not good
>at all!)
>
>The IDE is definitely missing something...
>
>Any thought ?
>Should there be a "flex-typedefs" folder , or a "royale-typedefs" folder
>? There is no such folder in the bin archive.
>
>Nicolas Granon
>
>
>
>
>> -----Message d'origine-----
>> De : Alex Harui [mailto:aharui@adobe.com]
>> Envoyé : vendredi 27 octobre 2017 00:02
>> À : ngranon@idylog.com; dev@royale.apache.org
>> Objet : Re: Apache Royale 0.9 setup
>> 
>> Hi Nicolas,
>> 
>> It is up to you as to whether to switch to VSCode or Moonshine.  We are
>> trying to keep FB working for Royale just so there is one less thing to
>> change to get started with Royale, but I expect Moonshine and VSCode to
>> eventually have more productivity features than FB will.
>> 
>> After investigating, I found that the problem was that the flex-
>> config.xml was invalid.  I worked around it by copying royale-
>> config.xml to flex-config.xml and changing the topmost tag in that
>> resulting flex-config.xml from <royale-config>...</royale-config> to
>> <flex-config>...</flex-config>
>> 
>> Then restart FB and see if it works better.
>> 
>> Thanks for working with us as we get the kinks out, -Alex
>> 
>> On 10/26/17, 6:27 AM, "Idylog - Nicolas Granon" <ngranon@idylog.com>
>> wrote:
>> 
>> >Thank you.
>> >If you think it's best to switch to VSCode or another editor, let us
>> know.
>> >
>> >Nicolas Granon
>> >
>> >
>> >
>> >> -----Message d'origine-----
>> >> De : Alex Harui [mailto:aharui@adobe.com] Envoyé : jeudi 26 octobre
>> >> 2017 08:05 À : dev@royale.apache.org; ngranon@idylog.com Objet : Re:
>> >> Apache Royale 0.9 setup
>> >>
>> >> I can reproduce it.  Looking into it.
>> >>
>> >> -Alex
>> >>
>> >> On 10/25/17, 10:22 PM, "Yishay Weiss" <yishayjobs@hotmail.com>
>> wrote:
>> >>
>> >> >Hi,
>> >> >
>> >> >Can you put an fxp somewhere so I can have a look?
>> >> >
>> >> >Thanks,
>> >> >Yishay
>> >> >
>> >> >From: Idylog - Nicolas Granon<mailto:ngranon@idylog.com>
>> >> >Sent: Thursday, October 26, 2017 1:05 AM
>> >> >To: dev@royale.apache.org<mailto:dev@royale.apache.org>
>> >> >Subject: RE: Apache Royale 0.9 setup
>> >> >
>> >> >I had only one namespace reference (it is a very small project!).
>> >> >Changed it as you say.
>> >> >Same result (same errors and autocomplete not working at all)
>> >> >
>> >> >Also noticed that syntax checking is not working anymore.
>> >> >
>> >> >Clearly, IDE is missing some link to syntax definitions...
>> >> >
>> >> >(tries to "clean project" : same result) (tries to close and reopen
>> >> >project : same result) (tried to close and restart IDE : same
>> >> >result)
>> >> >
>> >> >Also, there was a "flex-typedefs" folder in flexJS 0.8 but no such
>> >> >folder in
>> >> >0.9 (and no royale-typedefs).
>> >> >
>> >> >Nicolas Granon
>> >> >
>> >> >
>> >> >
>> >> >
>> >> >> -----Message d'origine-----
>> >> >> De : Peter Ent [mailto:pent@adobe.com.INVALID] Envoyé : mercredi
>> >> >> 25 octobre 2017 23:40 À : dev@royale.apache.org;
>> >> >> ngranon@idylog.com Objet : Re: Apache Royale 0.9 setup
>> >> >>
>> >> >> Hi,
>> >> >>
>> >> >> Yes - change all "flex" and "flexjs" to "royale". So the
>> namespace
>> >> >> will have "ns.apache.org/royale/basic".
>> >> >>
>> >> >> ‹peter
>> >> >>
>> >> >> On 10/25/17, 5:35 PM, "Idylog - Nicolas Granon"
>> >> >> <ngranon@idylog.com>
>> >> >> wrote:
>> >> >>
>> >> >> >Hi Alex,
>> >> >> >
>> >> >> >After downloading "apache.royale-jsonly-0.9.0-bin.zip" and
>> >> >> >unzipping, the "root" directory was accepted by flashbuilder
as
>> a
>> >> SDK directory.
>> >> >> >
>> >> >> >However my "stub" project now gives the following compile errors
>> :
>> >> >> >"internal error in file scope builder subsystem when generating
>> >> >> >(path to my project base mxml file) :
>> >> java.lang.nullpointerexception
>> >> >> Followed
>> >> >> >by two other errors (internal error in outgoing dependency
>> >> subsystem
>> >> >> >and internel error in syntax tree subsystem)
>> >> >> >
>> >> >> >Also, auto completion does not work anymore (I have deleted
old
>> >> >> imports
>> >> >> >like "import org.apache.flex.html.alert" because I suspected
>> that
>> >> >> >the "flex.html.alert" path was obsolete, but now, Flashbuilder
>> >> >> >cannot find Alert through autocomplete and thus cannot
>> >> automatically
>> >> >> >insert the correct import statement. The same for all classes
>> >> >> >(autocomplete shows "no suggestion")
>> >> >> >
>> >> >> >Something is missing somewhere...!
>> >> >> >
>> >> >> >Should I modify the namespace declarations
>> >> >> >"xmlns:js="library://ns.apache.org/flexjs/basic" ??
>> >> >> >
>> >> >> >Nicolas Granon
>> >> >> >
>> >> >> >
>> >> >> >
>> >> >> >
>> >> >> >> -----Message d'origine-----
>> >> >> >> De : Alex Harui [mailto:aharui@adobe.com] Envoyé : mercredi
25
>> >> >> >> octobre 2017 23:04 À : dev@royale.apache.org;
>> >> >> >> ngranon@idylog.com Objet : Re: Apache Royale 0.9 setup
>> >> >> >>
>> >> >> >> Hi Nicolas,
>> >> >> >>
>> >> >> >> Yeah, we are still fixing bugs after trying to rename
>> everything.
>> >> >> >> I was able to start with:
>> >> >> >>
>> >> >> >>
>> >> >>
>> >>
>> >>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapa
>> >> >> >>ch
>> >> >> e
>> >> >> >>fle
>> >> >> >>xbuild.cloudapp.net%3A8080%2Fjob%2Froyale-asjs-
>> >> >> &data=02%7C01%7C%7C7f61
>> >> >> >>d36
>> >> >>
>> >>
>> >>9db0945440eae08d51bf04bf6%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C
>> >> >> >>0%
>> >> >> 7
>> >> >> >>C63
>> >> >>
>> >>
>> >>6445641238635050&sdata=RJtXiuzNrCftM3HKUx7aWT1HS2X9szPLZd6DnwEhOtA%
>> >> >> >>3D
>> >> >> &
>> >> >> >>res
>> >> >> >>erved=0
>> >> >> >> jsonly/lastSuccess
>> >> >> >> fulBuild/artifact/out/
>> >> >> >>
>> >> >> >> And rename royale-sdk-description.xml to
>> >> >> >> flex-sdk-description.xml
>> >> >> and
>> >> >> >> change the closing tag to be flex-sdk-description and
FB
>> >> >> >> accepted that as an SDK on my Mac.
>> >> >> >>
>> >> >> >> HTH,
>> >> >> >> -Alex
>> >> >> >>
>> >> >> >> On 10/25/17, 11:22 AM, "Idylog - Nicolas Granon"
>> >> >> <ngranon@idylog.com>
>> >> >> >> wrote:
>> >> >> >>
>> >> >> >> >I would like to setup a Apache Royale 0.9 environment.
>> >> >> >> >I do not want to build it, just get the bin distribution.
>> >> >> >> >I have FlashBuilder setup (Windows).
>> >> >> >> >I am not interested in SWF output, just JS.
>> >> >> >> >
>> >> >> >> >1. Where is the latest bin distribution ? On Jenkins
there
>> are
>> >> >> >> >"royale-asjs", "royale-asjs-only", "royale-asjs-rename"
>> >> projects...
>> >> >> >> >Which is the correct one ?
>> >> >> >> >
>> >> >> >> >2. I have grabbed "apache-royale-0.9.0-bin.zip" from
>> >> >> >> >"royale-asjs-
>> >> >> >> rename".
>> >> >> >> >After unzipping, should I launch any ant task or is
it "ready
>> >> for
>> >> >> use"
>> >> >> >> ?
>> >> >> >> >
>> >> >> >> >3. I have noticed that in "royale-sdk-description.xml"
(in
>> the
>> >> >> >> >root
>> >> >> >> >dir) the opening tag (<flex-sdk-description>)
and closing tag
>> >> >> >> >(</royale-sdk-description>) do not match
>> >> >> >> >
>> >> >> >> >4 In Flashbuilder, you cannot "install" the SDK (it
did work
>> >> with
>> >> >> >> >FlexJS v 0.8). youget the following error : "Directory
does
>> >> >> >> >not
>> >> >> >> contain
>> >> >> >> >a Flex SDK".
>> >> >> >> >I have tried to copy and rename "royale-sdk-description.xml"
>> >> >> >> >as "flex-sdk-description.xml" and corrected the closing
tag
>> >> >> >> >(now
>> >> >> >> ></flex-sdk-description>) but still no luck.
What am I missing
>> ?
>> >> >> >> >
>> >> >> >> >5 What about environment variables (Windows) ?
>> >> >> >> >
>> >> >> >> >Many thanks in advance
>> >> >> >> >
>> >> >> >> >Nicolas Granon
>> >> >> >> >
>> >> >> >
>> >> >> >
>> >> >
>> >> >
>> >
>> >
>
>

Mime
View raw message