roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tudor Dabija <tudor.dab...@kepler-rominfo.com>
Subject RE: comment authentication failed
Date Thu, 06 Mar 2014 12:16:51 GMT
Ah sorry ... blog.site.ro is not the real one, right now is not accessible from outside it
was just obfuscated to something 'site.ro' :) I wasn't aware that blog.site.ro actually exist.


Anyway, beside this issue with comment authentication failed there is also another issue:

The authentication for roller administration page works from http://blog.site.ro:8080/roller/roller-ui/
but the user/password combination is failing when trying to access from http://blog.site.ro/roller-ui/
(the page shows correctly and asks for username and password)

This makes me think that the http proxy is somehow not forwarding correctly some fields -
in the first case the response to the mathematical question in the second case the password
for roller Administrator user.

As below there are NO messages in httpd logs or roller logs. 

Is there another way to setup the proxy mode in httpd server to forward correctly these post's?
I am not stuck with ajp as I have seen different setups with mod_proxy but I need a working
setup that does this: reroute port 80 incoming requests to http://blog.site.ro to http://blog.site.ro:8080/roller
and show the weblog with no "/roller/" appends.

Tudor Dabija





-----Original Message-----
From: David Ghedini [mailto:david@davidghedini.com] 
Sent: Thursday, March 06, 2014 1:45 PM
To: user@roller.apache.org
Cc: user@roller.apache.org
Subject: Re: comment authentication failed

Sorry - I misread it as comment notification.
Where does authentication fail?
I looked at site and didn't see a comment section.

Sent from my iPhone

On 6 2014, at 11:04, Tudor Dabija <tudor.dabija@kepler-rominfo.com> wrote:

> Hello,
> 
> I am nost seeing anything in mail logs ... if has anything to do with mail logs.
> 
> Below are some snippets from configuration files, maybe anyone can help with this issue.
> 
> Roller-custom.properties:
> 
> installation.type=manual
> mediafiles.storage.dir=/usr/local/rollerdata/mediafiles
> search.index.dir=/usr/local/rollerdata/searchindex
> #log4j.appender.roller.File=/usr/local/rollerdata/roller.log
> database.configurationType=jdbc
> database.jdbc.driverClass=org.postgresql.Driver
> database.jdbc.connectionURL=jdbc:postgresql://localhost:5432/roller?
> autoReconnect=true&useUnicode=true&characterEncoding=utf-8&postgresqlEncoding=utf8
> database.jdbc.username=obfuscated
> database.jdbc.password=obfuscated
> mail.configurationType=properties
> mail.hostname=mx.site.ro
> mail.username=blog-editors@site.ro
> #mail.password=tiger
> weblog.absoluteurl.Kepler=http://blog.site.ro   < this is a handler to inform roller
with his blog to respond correctly to this address
> comment.authenticator.classname=\org.apache.roller.weblogger.ui.rendering.plugins.comments.DefaultCommentAuthenticator
  < this was added to disable the comment authenticator because otherwise I receive the
error
> 
> 
> server.xml for tomcat
> 
> <Connector port="8009" protocol="AJP/1.3" URIEncoding="UTF-8" redirectPort="8443"
/>       < the ajp connector
> 
> <Host name="localhost"  appBase="webapps"
>            unpackWARs="true" autoDeploy="true"
>            xmlValidation="false" xmlNamespaceAware="false">
>        <Alias>blog.site.ro</Alias>  
> 
> 
> Httpd.conf
> 
> <VirtualHost blog.site.ro:80>
>    ServerAdmin webmaster@kepler-rominfo.com
>    #DocumentRoot /var/www/html
>    ServerName blog.site.ro
>    ErrorLog logs/blog.error.log
>    CustomLog logs/blog.access.log combined
> 
>        ProxyPass /roller !  < this was added because I want the site to be http://blog.site.ro
and not http://blog.site.ro/roller (therefore i remove the ending /roller)
>        ProxyPass /  ajp://localhost:8009/roller/
>        ProxyPassReverse / http://blog.site.ro/
> 
>        RedirectMatch 301 ^/roller/(.*)$ http://blog.site.ro/$1      < this lines were
added to match 301 redirects correctly (the full site url was used because of unfixed bug
in httpd 2.2.15 still delivered with centos and redhat 6.5)
>        RedirectMatch 301 ^/roller$ http://blog.site.ro/
> 
> 
> </VirtualHost>
> 
> 
> 
> Any ideas?
> 
> 
> 
> Tudor Dabija
> 
> 
> -----Original Message-----
> From: David Ghedini [mailto:david@davidghedini.com] 
> Sent: Wednesday, March 05, 2014 8:41 PM
> To: user@roller.apache.org
> Cc: user@roller.apache.org
> Subject: Re: comment authentication failed
> 
> Anything in the mail logs?
> 
> Sent from my iPhone
> 
> On 5 2014, at 19:35, Tudor Dabija <tudor.dabija@kepler-rominfo.com> wrote:
> 
>> Hello,
>> 
>> I am using roller version 5.0.3 on a centos 6.5 with tomcat 6 and postgresql DB.
>> Also I am using http proxy with ajp to forward requests on 80 port to 8080 tomcat
>> 
>> I have an issue with comments as I receive an authentication failed. There are no
loged errors in http or roller.
>> 
>> How can I solve this?
>> 
>> If any other configuration is neede I will provide.
>> 
>> 
>> Thank you,
>> 
>> 
>> Tudor

Mime
View raw message