roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Johnson <snoopd...@gmail.com>
Subject Re: Roller 5 - uploaded media files not available for selection
Date Tue, 10 Jan 2012 13:56:58 GMT
I haven't seen that behavior. I wonder if it is something specific to Glassfish 3.1.1 and the
EclipseLink JPA used in Glassfish. Does this happen for all media types or just PNG?

- Dave


On Jan 6, 2012, at 1:55 AM, Dave Koelmeyer wrote:

> On 12/25/11 11:03 PM, Dave Koelmeyer wrote:
>> Hi All,
>> 
>> I have installed Roller 5.0 on the following platform:
>> 
>> GlassFish 3.1.1
>> PostgreSQL 8.4
>> JDK 6u26
>> 
>> In Roller I have created both an admin account and a standard user account, but otherwise
have not performed much else in the way of configuration or customization, aside from adding
the "Lightword" theme.
>> 
>> My issue is that I can apparently upload media files (e.g. PNG images) using the
"Media Files" feature, but uploaded files do not appear as selectable items in the Media Files
view - except after restarting the application server.
>> 
>> For example:
>> 
>> 1) Log into Roller as a standard (i.e. non-admin user)
>> 2) Click on "Create and Edit" -> "New Entry", and fill out some blog information
(title, content etc.)
>> 3) Click on the "Media Files" tab
>> 4) On the "Actions" area on the right-hand side, click on "Add Media File"
>> 5) Choose a file to upload (example is a PNG file), and click on "Upload"
>> 6) Roller reports success:
>> 
>> "Uploaded file(s):
>> "https://192.168.1.1:8081/roller/dave/mediaresource/5f4670f......"
>> 
>> 7) Click on "Return to Media File View"
>> 
>> At this point I would expect to see my file visible for selection here, but I don't.
Flicking the "Sort by" setting across "Name", "Date" and "Type" filters doesn't change the
behaviour. Strangely, if at this point I search for the file (on the right hand side menu)
explicitly for the file type "Image", the image is successfully located and displayed in the
Media Files view.
>> 
>> If I create a new blog entry or edit an existing entry and click on the "Add Image"
link (I have the Xinha editor enabled), the image I have uploaded is not visible in the "Media
File Chooser" window that appears.
>> 
>> As mentioned, if I restart GlassFish, the images are then visible in the Media File
view and available for selection in the "Media File Chooser" window.
>> 
>> Any ideas?
>> 
> 
> Bump - anyone?
> 
> (and apologies to whoever is moderating this list - I have only just realised that I
have been getting my subscribed email addresses mixed up).
> 
> Cheers,
> Dave
> 


Mime
View raw message