roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Purl <...@tompurl.com>
Subject Data Source Not Found When Deploying 5.0 On Jboss 6.0
Date Wed, 29 Jun 2011 12:21:12 GMT
OS: Ubuntu Server 10.4

I used the standard notes to set up Roller 5.0 on Jboss 6.0. However, I am
getting the following error now that I am trying to deploy the "javaee" binary:

    Deployment "jboss.jca:name=jdbc/rollerdb,service=DataSourceBinding"
is in error
    due to the following reason(s): ** NOT FOUND Depends on
    'jboss.jca:name=jdbc/rollerdb,service=DataSourceBinding' **

Is the application expecting a data source named "rollerdb"? If so, then where
is it getting that value? I specified the "standard" data source name in my
roller-custom.properties file:

    tom@millhouse:/usr/local/jboss/server/default/conf$ cat
roller-custom.properties
    installation.type=auto
    mediafiles.storage.dir=/usr/local/rollerdata/mediafiles
    search.index.dir=/usr/local/rollerdata/searchindex
    log4j.appender.roller.File=/usr/local/rollerdata/roller.log
    database.jndi.name=java:/RollerDS

This file is owned by the jboss user.

I have a jndi data source called RollerDS that I created, configured and tested
using the admin console. Here are the contents of RollerDS-ds.xml:

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <datasources>
        <no-tx-datasource>
            <jndi-name>RollerDS</jndi-name>
            <rar-name>jboss-local-jdbc.rar</rar-name>
            <use-java-context>true</use-java-context>
            <connection-definition>javax.sql.DataSource</connection-definition>
            <jmx-invoker-name>jboss:service=invoker,type=unified</jmx-invoker-name>
            <min-pool-size>0</min-pool-size>
            <max-pool-size>10</max-pool-size>
            <blocking-timeout-millis>30000</blocking-timeout-millis>
            <idle-timeout-minutes>30</idle-timeout-minutes>
            <prefill>false</prefill>
            <background-validation>false</background-validation>
            <background-validation-millis>0</background-validation-millis>
            <validate-on-match>true</validate-on-match>
            <statistics-formatter>org.jboss.resource.statistic.pool.JBossDefaultSubPoolStatisticFormatter</statistics-formatter>
            <isSameRM-override-value>false</isSameRM-override-value>
            <allocation-retry>0</allocation-retry>
            <allocation-retry-wait-millis>5000</allocation-retry-wait-millis>
            <security-domain xsi:type="securityMetaData"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"/>
            <metadata/>
            <prepared-statement-cache-size>0</prepared-statement-cache-size>
            <share-prepared-statements>false</share-prepared-statements>
            <set-tx-query-timeout>false</set-tx-query-timeout>
            <query-timeout>0</query-timeout>
            <url-delimiter>|</url-delimiter>
            <driver-class>com.mysql.jdbc.Driver</driver-class>
            <connection-url>jdbc:mysql://localhost:3306/rollerdb</connection-url>
        </no-tx-datasource>
    </datasources>

I have a database with the following properties:

DB Name: rollerdb
User: rollerdbo

I am also able to log into mysql and access that database using the rollerdbo
user.

And here are the contents of my rollerdata directory:

    tom@millhouse:/usr/local/jboss/server/default/conf$ ls -l
/usr/local/rollerdata/
    total 32
    drwxr-xr-x 2 jboss jboss  4096 2011-06-24 15:39 mediafiles
    -rw-r--r-- 1 jboss jboss 22566 2011-06-24 15:47 roller.log
    drwxr-xr-x 2 jboss jboss  4096 2011-06-24 15:39 searchindex

Does anyone know what I might be doing wrong?

Thanks in advance!

Tom Purl

Mime
View raw message