roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nelson Chamberlain <nchamberl...@ceradyne.com>
Subject RE: Memory leak, slow performance in Roller 5 on Tomcat 7
Date Tue, 21 Jun 2011 15:29:07 GMT
What does Task Manager show is happening when you try to load Main Menu? Is the processor running
at 100% or is it loafing?  What about memory usage? Is system memory almost used up or is
does it have lots of room? If you sort your processes by Memory footprint, is there one that
is consuming excessive amounts of memory, causing Windows Virtual Memory to be used? Does
the hard drive run continuously when you try to load Main Menu?

What about the Tomcat logs? Any errors being reported? What about the Windows Event Viewer?
Does it show any errors? I had an XP system that used to take 3 minutes to go from successful
login to display of the desktop that was caused by XP patiently waiting for a non-existent
process to time out and would dutifully report the error in the Event Viewer (but not on screen).
 Maybe something like that is happening when the slow pages are trying to load?

Nelson

-----Original Message-----
From: Matt Raible [mailto:matt@raibledesigns.com] 
Sent: Monday, June 20, 2011 8:26 PM
To: user@roller.apache.org; Dean Schulze
Subject: Re: Memory leak, slow performance in Roller 5 on Tomcat 7

I'd try bumping up your memory. Set a JAVA_OPTS (or CATALINA_OPTS) environment variable with
something like the following:

-server -Xms256M -Xmx256M -XX:PermSize=128M

On Mon, Jun 20, 2011 at 7:45 PM, Dean Schulze <dean_w_schulze@yahoo.com>wrote:

>
>
> When loading the Front Page and the one other blog I have created the 
> performance is good (< 3 seconds).
>
> The problems start when I click Main Menu from the Front Page:
>
>   Main Menu:  115 seconds.
>   Login:  45 seconds
>   Entries (from MainMenu):  80 seconds
>   Edit (from Edit Entries):  > 60 seconds
>
> I also noticed that the content for the FrontPage does not get displayed.
>
> My hardware is Intel Core duo (about 4 years old).  Windows XP, 
> default JVM settings for Tomcat 7.0.16.
>
>
>
>
> ________________________________
> From: Dave <snoopdave@gmail.com>
> To: user@roller.apache.org; Dean Schulze <dean_w_schulze@yahoo.com>
> Sent: Sunday, June 19, 2011 3:15 PM
> Subject: Re: Memory leak, slow performance in Roller 5 on Tomcat 7
>
> On Sun, Jun 19, 2011 at 10:41 AM, Dean Schulze 
> <dean_w_schulze@yahoo.com>
> wrote:
> > I installed the pre-packaged roller-5.0.0-tomcat.war on a new Tomcat
> 7.0.16 on Windows XP and created 2 users and 2 blogs.  I let Roller 5 
> run overnight and memory usage went from 237 MB to 262 MB.
> >
> > Is there a good reason for Roller to need 10% more memory when it 
> > has
> been inactive, or is this a memory leak?
>
> I'm not aware of a memory leak, but it is certainly possible that 
> something in Roller or some component of Roller has a leak.
>
>
> > Roller 5 is also frustratingly slow even when returning to 
> > previously
> rendered pages.
> > First access is very slow, but I can understand that. Is there 
> > something
> I can do
> > through configuration to improve performance?
>
> Roller works fine for me and page loads are adequately speedy. Can you 
> be more specific about a) the environment under which you are running 
> Roller (hardware, Java VM settings) and b) page load times.
>
> - Dave
>
Mime
View raw message