roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Van Rogers-Ho <vanonthe...@gmail.com>
Subject Re: RefreshRollerPlanetTask not running
Date Fri, 01 Apr 2011 05:29:04 GMT
Ok. I was able to get it working. Looks like it's related to Oracle specific
date precision.

[jira] Commented: (ROL-1760) Scheduled tasks do not run on Oracle (or other
DBs with high precision timestamps)

I ran following for Oracle:

update ROLLER.ROLLER_TASKLOCK
set timeacquired = null,
lastrun=null;

commit;

alter table roller_tasklock modify timeacquired  timestamp(2) with time
zone;
alter table roller_tasklock modify lastrun  timestamp(2) with time zone;
I'm getting recent entries on my front page and /planetrss now.

Thanks,
Van

On Thu, Mar 31, 2011 at 7:16 PM, Van Rogers-Ho <vanontherun@gmail.com>wrote:

> Hi,
>
> I'm hoping someone can provide some files and logs to look at to diagnose
> why RefreshRollerPlanetTask:runTask  is no longer running.
> It looks like a few weeks ago (mid march), it stopped. I looked at old
> roller.log and noted the following:
>
>
> INFO  2011-03-13 00:05:00,067 RefreshRollerPlanetTask:runTask - Refreshing
> Planet subscriptions
>
> In latest roller.log, I don't see this message, nor do I see any type of
> errors. Is there a way to manually fire off the task to check for errors in
> logs? Any planet specific log?
>
> I also cleared out my ROLLER.RAG_ENTRY table to get rid of any junk.
>
> Running: 4.0.1 on WLS 11g, and Oracle db.
>
> Thanks,
> Van
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message