roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Johnson <snoopd...@gmail.com>
Subject Re: rc5 versus windows live writer
Date Wed, 06 Apr 2011 03:44:53 GMT
I just realized, I tested Live Writer with AtomPub and not MetaWeblog, so please try AtomPub
instead and I'll try LW with MetaWeblog and see if I can reproduce those errors. 

Thanks,
- Dave



Sent from my iPad

On Apr 5, 2011, at 11:02 PM, "Peter Evans" <peter@ixp.jp> wrote:

> Note: could be pilot error, the pilot doesn't know what he is doing.
> 
> 1 - installed windows live writer 2011 (this is W7)
> 2 - added a blog account, let it decide what it was.
>   under pictures in Blog options, "blog service"
> 
> Capability
> Y    post draft to server
> Y    file upload
> N    extended entries
> Y    custom publish date
> Y    update publish date
> Y    categories
> Y    categories inline
> Y    multiple categories
> N    hierarchical categories
> N    new categories
> N    new categories inline
> -    category scheme
> N    keywords
> N    keyword retrieval
> N    comment policy
> N    trackback policy
> N    author
> N    slug
> N    password
> N    excerpt
> N    send trackbacks
> N    pages
> N    page parent
> N    page order
> Y    HTML titles
> Y    Empty titles
> ?    scripts
> ?    embeds
> 
> Normal    Default View
> utf-8    Encoding
> 
> N    requires XHTML
> N    template is right-to-left
> -    category name limit
> Y    auto-update
> -    title length limit
> 
> 3 - create a simple post "test"  OK
> 
> 4 - try to create a post with an image
>       post creates ok, with a place holder for the image, but I see no image.
>       And this is where it might be pilot error, looking in the access log I see no attempt
to upload an image
>   (it's 155kb) All I see are a few
> 
> "127.0.0.1" "NULL-AUTH-USER" "06/Apr/2011:11:34:29 +0900" "POST /roller/roller-services/xmlrpc
HTTP/1.1" 200 408
> "127.0.0.1" "NULL-AUTH-USER" "06/Apr/2011:11:34:47 +0900" "POST /roller/roller-services/xmlrpc
HTTP/1.1" 200 866
> "127.0.0.1" "NULL-AUTH-USER" "06/Apr/2011:11:34:47 +0900" "POST /roller/roller-services/xmlrpc
HTTP/1.1" 200 1607
> "127.0.0.1" "NULL-AUTH-USER" "06/Apr/2011:11:34:47 +0900" "POST /roller/roller-services/xmlrpc
HTTP/1.1" 200 411
> "127.0.0.1" "NULL-AUTH-USER" "06/Apr/2011:11:35:07 +0900" "POST /roller/roller-services/xmlrpc
HTTP/1.1" 200 411
> "127.0.0.1" "NULL-AUTH-USER" "06/Apr/2011:11:49:41 +0900" "POST /roller/roller-services/xmlrpc
HTTP/1.1" 200 411
> 
>   how does image upload work?
> 
> 5 - additionally, if you try to republish something.
> 
> Server Error 0 Occurred
> 
> Failed to invoke method editPost in class org.apache.roller.weblogger.webservices.xmlrpc.MetaWeblogAPIHandler:
0
> 
>   maybe that is also "pilot is an idiot and shouldn't even be allowed to fly a toy train
set."
> 
>   P
> 
> 
> 
> 

Mime
View raw message