roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave <snoopd...@gmail.com>
Subject Re: rc4 testing - headshot with JPA on glassfish v3.1 -.-
Date Fri, 11 Mar 2011 12:58:38 GMT
On Wed, Mar 9, 2011 at 5:07 AM, Peter Evans <peter@ixp.jp> wrote:
> Tried to turn on planet aggregator, it complained about the cache.dir (which
> is NOT as the document says)

What is the problem here? Does the Install Guide use the wrong name
for the "cache.dir" property?


> After that, whatever it did was fatal.
> And, from the really no sure what we did here department:
>
> INFO  2011-03-09 18:41:31,417 WebloggerFactory:bootstrap - Roller Weblogger
> business tier successfully bootstrapped
> INFO  2011-03-09 18:41:31,417 WebloggerFactory:bootstrap -    Version:
> 5.0.0-RC4
> INFO  2011-03-09 18:41:31,417 WebloggerFactory:bootstrap -    Revision:
> r1075074
> INFO  2011-03-09 18:41:31,418 WebloggerImpl:initialize - Initializing Roller
> Weblogger business tier
> FATAL 2011-03-09 18:41:31,420 JPAPropertiesManagerImpl:initialize - Failed
> to initialize runtime configuration properties.Please check that the
> database has been upgraded!
> java.lang.ClassCastException:
> org.apache.roller.weblogger.pojos.RuntimeConfigProperty cannot be cast to
> org.apache.roller.weblogger.pojos.RuntimeConfigProperty
>       at
> org.apache.roller.weblogger.business.jpa.JPAPropertiesManagerImpl.getProperties(JPAPropertiesManagerImpl.java:127)
>       at
> org.apache.roller.weblogger.business.jpa.JPAPropertiesManagerImpl.initialize(JPAPropertiesManagerImpl.java:77)
>       at
> org.apache.roller.weblogger.business.WebloggerImpl.initialize(WebloggerImpl.java:338)
>
>   etc, etc, lots of USELESS traceback that does not actually tell me what I
> did wrong.

That's a pretty mysterious error there, RuntimeConfigProperty cannot
be cast to RuntimeConfigProperty. What platform are you running on?
Operating system, Java version, App server, etc.

Do you have two copies of the Roller jars in your WEB-INF/lib
directory? That could cause this problem.

Thanks,
Dave



>   Almost certainly something in roller-custom.porpoises.
>   whatever the JPA thing is, its not giving any clues as to what the
> _actual_ cause is, and it basically
>   explodes.
>
> installation.type=auto
> #database.configurationType=jndi
> #database.jndi.name=jdbc/rollerdb
>
> mediafiles.storage.dir=/home/www2/rollerdata/mediafiles
> search.index.dir=/home/www2/rollerdata/searchindex
> log4j.appender.roller.File=/home/www2/rollerdata/roller.log
>
> planet.aggregator.enabled=false
>
>

Mime
View raw message