roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave <snoopd...@gmail.com>
Subject Re: roller 4.0.1 deploy error on glassfish v3.0.1; seems to work fine on glassfish v2ur2
Date Wed, 22 Dec 2010 13:44:42 GMT
It is possible that Roller 4 will not run on the new Java EE 6 app
servers because it depends on one specific version of JPA 1.0 (Apache
OpenJPA 0.9.7) and that version conflicts with the JPA implementation
there.

I've been testing Roller 5 against Glassfish 3, JBoss 6 and WebSphere
8 and hope to have a new Roller 5.0 RC3 build available for wider
testing at the the end of the holiday break.

- Dave



On Mon, Dec 20, 2010 at 6:57 PM, emiddio-frontier <emiddio@frontier.com> wrote:
>
> roller obtained from http://roller.apache.org/downloads.html
>
> version 4.0.1
>
> file attached is .txt file -- of the glassfish v301 deploy log exceptions.
>
> again --seems to work fine with gfv2ur2
>
> Gary
>
> Looking for ideas how to resolve; using the binary Apache Roller 4.0.1
> distro directory based War
>
> only had to configure the jdbc/rollerdb on gfv2ur2 to get roller fully
> functional.
>
> same config done on gfv301 -- but deployment fails with class not found
> exception -- something
> aproximating org.apache.openjpa... class not found
>
> the Jar file containing the not found class in the the lib dir of the
> webapp. the jar file containg the class
> is named openjpa-0.9.7-incubating.jar
>
>
> thanks
>
> gary
>

Mime
View raw message