roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amit Mittal <amitmitt...@gmail.com>
Subject Prob in running Apache Roller 4.0.1 webblogger in WAS 6.1 - seems Sturts 2-xwork error
Date Mon, 06 Sep 2010 12:01:54 GMT
Hi Dave,
I am running Apache Roller 4.0 in WAS 6.1. When I run that in the WAS
installed in my local windows machine it runs fine however when I deploy the
same application WAR in WAS 6.1 running on AIX Server machine, I gets the
application error page in the browser however no error in the logs. The only
difference I see between my local WAS and server machine WAS is following
line is missing in server log:

*com.opensymphony.xwork2.validator.ActionValidatorManagerFactory <clinit>
Detected AnnotationActionValidatorManager, initializing it...*

Here are the server details and logs:

In Local machine- WebSphere Application Server v6.1.0.19 on Windows XP
---------------------------------------------------------------------
When we run the same application in our local WAS (version: ND 6.1.0.19 with
no feature pack), here are the logs:

[9/6/10 15:23:04:062 IST] 00000026 RequestMappin I
org.apache.roller.weblogger.ui.rendering.filters.RequestMappingFilter init
Request mapping filter initialized, 1 mappers configured.
[9/6/10 15:23:04:375 IST] 00000026 XmlConfigurat I
com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register
Parsing configuration file [struts-default.xml]
[9/6/10 15:23:04:656 IST] 00000026 XmlConfigurat I
com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register
Parsing configuration file [struts-plugin.xml]
[9/6/10 15:23:04:703 IST] 00000026 XmlConfigurat I
com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register
Parsing configuration file [struts.xml]
[9/6/10 15:23:04:781 IST] 00000026 Settings W
org.apache.struts2.config.Settings getLocale Settings: Could not parse
struts.locale setting, substituting default VM locale
[9/6/10 15:23:04:796 IST] 00000026 BeanSelection I
org.apache.struts2.config.BeanSelectionProvider register Loading global
messages from ApplicationResources
[9/6/10 15:23:05:000 IST] 00000026 StrutsSpringO I
org.apache.struts2.spring.StrutsSpringObjectFactory <init> Initializing
Struts-Spring integration...
[9/6/10 15:23:05:000 IST] 00000026 SpringObjectF I
com.opensymphony.xwork2.spring.SpringObjectFactory setAutowireStrategy
Setting autowire strategy to name
[9/6/10 15:23:05:000 IST] 00000026 StrutsSpringO I
org.apache.struts2.spring.StrutsSpringObjectFactory <init> ... initialized
Struts-Spring integration successfully
[9/6/10 15:23:06:078 IST] 00000026 ObjectTypeDet I
com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory <clinit> Setting
DefaultObjectTypeDeterminer as default ...
[9/6/10 15:23:06:484 IST] 00000026 ServletWrappe I SRVE0242I: [roller_WAR]
[/roller] [FilterProxyServlet]: Initialization successful.
*[9/6/10 15:23:06:656 IST] 00000026 ServletWrappe I SRVE0242I: [roller_WAR]
[/roller] [/index.jsp]: Initialization successful.*
*[9/6/10 15:23:07:109 IST] 00000026 ActionValidat I
com.opensymphony.xwork2.validator.ActionValidatorManagerFactory <clinit>
Detected AnnotationActionValidatorManager, initializing it...
[9/6/10 15:23:11:484 IST] 00000026 ServletWrappe I SRVE0242I: [roller_WAR]
[/roller] [/WEB-INF/jsps/tiles/tiles-simplepage.jsp]: Initialization
successful.
[9/6/10 15:23:12:984 IST] 00000026 ServletWrappe I SRVE0242I: [roller_WAR]
[/roller] [/WEB-INF/jsps/tiles/head.jsp]: Initialization successful.
[9/6/10 15:23:13:093 IST] 00000026 ServletWrappe I SRVE0242I: [roller_WAR]
[/roller] [/WEB-INF/jsps/tiles/css-nosidebar.jsp]: Initialization
successful.
[9/6/10 15:23:13:140 IST] 00000026 ServletWrappe I SRVE0242I: [roller_WAR]
[/roller] [/WEB-INF/jsps/tiles/empty.jsp]: Initialization successful.
[9/6/10 15:23:13:359 IST] 00000026 ServletWrappe I SRVE0242I: [roller_WAR]
[/roller] [/WEB-INF/jsps/tiles/bannerStatus.jsp]: Initialization successful.
[9/6/10 15:23:14:546 IST] 00000026 ServletWrappe I SRVE0242I: [roller_WAR]
[/roller] [/WEB-INF/jsps/tiles/messages.jsp]: Initialization successful.
[9/6/10 15:23:14:750 IST] 00000026 ServletWrappe I SRVE0242I: [roller_WAR]
[/roller] [/WEB-INF/jsps/core/Setup.jsp]: Initialization successful.
[9/6/10 15:23:14:968 IST] 00000026 ServletWrappe I SRVE0242I: [roller_WAR]
[/roller] [/WEB-INF/jsps/tiles/footer.jsp]: Initialization successful.*

In Server - WebSphere Application Server Base 6.1.0.27 with no feature pack
on AIX
-----------------------------------------------------------------

[9/6/10 14:49:10:048 MYT] 00000041 RequestMappin I
org.apache.roller.weblogger.ui.rendering.filters.RequestMappingFilter init
Request mapping filter initialized, 1 mappers configured.
[9/6/10 14:49:10:168 MYT] 00000041 XmlConfigurat I
com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register
Parsing configuration file [struts-default.xml]
[9/6/10 14:49:10:252 MYT] 00000041 XmlConfigurat I
com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register
Parsing configuration file [struts-plugin.xml]
[9/6/10 14:49:10:286 MYT] 00000041 XmlConfigurat I
com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register
Parsing configuration file [struts.xml]
[9/6/10 14:49:10:296 MYT] 00000041 Settings W
org.apache.struts2.config.Settings getLocale Settings: Could not parse
struts.locale setting, substituting default VM locale
[9/6/10 14:49:10:313 MYT] 00000041 BeanSelection I
org.apache.struts2.config.BeanSelectionProvider register Loading global
messages from ApplicationResources
[9/6/10 14:49:10:379 MYT] 00000041 StrutsSpringO I
org.apache.struts2.spring.StrutsSpringObjectFactory <init> Initializing
Struts-Spring integration...
[9/6/10 14:49:10:388 MYT] 00000041 SpringObjectF I
com.opensymphony.xwork2.spring.SpringObjectFactory setAutowireStrategy
Setting autowire strategy to name
[9/6/10 14:49:10:401 MYT] 00000041 StrutsSpringO I
org.apache.struts2.spring.StrutsSpringObjectFactory <init> ... initialized
Struts-Spring integration successfully
[9/6/10 14:49:10:886 MYT] 00000041 ObjectTypeDet I
com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory <clinit> Setting
DefaultObjectTypeDeterminer as default ...
[9/6/10 14:49:10:952 MYT] 00000041 ServletWrappe I SRVE0242I: [roller_WAR]
[/rol] [FilterProxyServlet]: Initialization successful.
*[9/6/10 14:49:10:989 MYT] 00000041 ServletWrappe I SRVE0242I: [roller_WAR]
[/rol] [/index.jsp]: Initialization successful.
[9/6/10 14:49:11:016 MYT] 00000041 ServletWrappe I SRVE0242I: [roller_WAR]
[/rol] [/roller-ui/errors/404.jsp]: Initialization successful.*

Thanks for your help.

Thanks
Amit

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message