roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Levine <levine_br...@hotmail.com>
Subject RE: Usage for MetaWeblog API for deletePost.
Date Fri, 30 Oct 2009 22:01:15 GMT


Have you tried adding
log4j.category.org.apache.roller.weblogger.webservices.xmlrpc=DEBUG

to your roller-custom.properties file?  That should give you some more information on what's
going on.

Have you tried adding or editing posts?  And does that work?

Do you have preferences->settings->Enable weblog client support selected?  I believe
admin and atom protocols are separate from xmlrpc, but I wouldn't bet my life on it or anything.

/Brian


> Date: Fri, 30 Oct 2009 14:19:56 -0700
> From: mkod_sf@yahoo.com
> Subject: Usage for MetaWeblog API for deletePost.
> To: user@roller.apache.org
> 
> Hi -
> 
> I am trying to delete a post using MetaWeblog API. My code is as folows:
> 
>         Boolean result = (Boolean) client.execute("metaWeblog.deletePost",
>             new Object[] {appKey, postId, username, password, Boolean.TRUE});
> 
> When I run this code I always get back false and the post is not deleted from the roller
database.
> 
> I also have the following settings in my roller-custom.properties file:
> 
> webservices.atomprotocol.enabled=true
> webservices.adminprotocol.enabled=true
> 
> What am I doing wrong? How come I cannot delete the post?
> 
> Any pointers will be welcome.
> 
> Manu
> 
> 
>       
 		 	   		  
_________________________________________________________________
Windows 7: I wanted more reliable, now it's more reliable. Wow!
http://microsoft.com/windows/windows-7/default-ga.aspx?h=myidea?ocid=PID24727::T:WLMTAGL:ON:WL:en-US:WWL_WIN_myidea:102009
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message