roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matej Lazar <matejon...@gmail.com>
Subject Re: deploy to jboss 5.1 - You have not defined a non-jta-data-source
Date Sat, 24 Oct 2009 13:57:47 GMT

Now I have different type of error
"java.lang.ClassNotFoundException: org.apache.openjpa.util.CacheMap" 
although openjpa-0.9.7-incubating.jar is in lib folder. See attached log.

Tried with and without
<loader-repository-config>java2ParentDelegation=false</loader-repository-config>

Tried also to delete DB tables, but cannot start roller again to access 
the install page. Then I created tables manually from script, but error 
is always the same.


--
matej


Dave wrote:
> I don't see any indication of a problem in your log files.
>
> I do see that your custom properties are read successfully.
> Your database connection is established successfully.
> Your mail server is not configured, but that's OK
> Then Roller thinks you need to do a database create or upgrade, not sure why.
>
> Anybody JBoss users out there have pointers?
>
> - Dave
>
>
> On Fri, Oct 23, 2009 at 2:24 PM, Matej Lazar <matejonnet@gmail.com> wrote:
>   
>> Dave wrote:
>>     
>>> On Thu, Oct 22, 2009 at 3:27 AM, Matej Lazar <matejonnet@gmail.com> wrote:
>>>
>>>       
>>>> First I tried to deploy roller 4.0.1 then latest from trunk, but allways
>>>> get
>>>> error mesage, that I have not defined "non jta data source".
>>>>
>>>> I did just as it is described in installation guide... created datebase,
>>>> created a roller-custom.properties (JDBC). Put it in WEB-INF\classes\
>>>> (tried
>>>> also elsewhere - all meta-inf folders )
>>>>
>>>> I have required libs in server lib dir
>>>> jboss-5.1.0.GA\server\default\lib\mysql-connector-java-5.0.8-bin.jar
>>>>
>>>> Tried to deploy as war and as ear project, tried to play with
>>>> resource-ref
>>>> in web.xml
>>>>
>>>> How can I check that roller-custom.properties file is loaded, because I
>>>> get
>>>> the same error if I remove it ?
>>>>
>>>>         
>>> I don't think you are looking at the right log file.
>>>
>>> When Roller attempts to load the properties file, it logs the results
>>> at INFO level in the roller.log file.
>>>
>>> - Dave
>>>
>>>
>>>       
>> Despite of errors the application started I said, that connection to
>> database successed and offer me to create tables.
>> After table creation there was unexpected error which was not logged
>> anywhere.
>> Tables are created but I cannot access application anymore, neither with
>> setting installation.type=auto or manual
>>
>> --
>> Matej
>>
>>     
>
>   


Mime
View raw message