roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matej Lazar <matejon...@gmail.com>
Subject Re: deploy to jboss 5.1 - You have not defined a non-jta-data-source
Date Fri, 23 Oct 2009 18:09:15 GMT
Dave wrote:
> On Thu, Oct 22, 2009 at 3:27 AM, Matej Lazar <matejonnet@gmail.com> wrote:
>   
>> First I tried to deploy roller 4.0.1 then latest from trunk, but allways get
>> error mesage, that I have not defined "non jta data source".
>>
>> I did just as it is described in installation guide... created datebase,
>> created a roller-custom.properties (JDBC). Put it in WEB-INF\classes\ (tried
>> also elsewhere - all meta-inf folders )
>>
>> I have required libs in server lib dir
>> jboss-5.1.0.GA\server\default\lib\mysql-connector-java-5.0.8-bin.jar
>>
>> Tried to deploy as war and as ear project, tried to play with resource-ref
>> in web.xml
>>
>> How can I check that roller-custom.properties file is loaded, because I get
>> the same error if I remove it ?
>>     
>
> I don't think you are looking at the right log file.
>
> When Roller attempts to load the properties file, it logs the results
> at INFO level in the roller.log file.
>
> - Dave
>
>   

If I don't comment out resource-ref for jdbc and mail in web.xml, then 
roller logs are empty and I don't get message "Successfully loaded 
custom properties" in console.

If I comment out then I get console message:
19:40:57,187 INFO  [STDOUT] Roller Weblogger: Successfully loaded custom 
properties file from classpath

but before this mesage there is:
19:40:56,250 ERROR [AbstractKernelController] Error installing to Start: 
name=persistence.unit:unitName=#RollerPU state=Create
java.lang.RuntimeException: Specification violation [EJB3 JPA 6.2.1.2] - 
You have not defined a non-jta-data-source for a RESOURCE_LOCAL enabled 
persistence context named: RollerPU
...

In roller.log is nothig about custom properties (see attachment).

I'm deploying application as extracted war, properties file is in 
WEB-INF\classes\

Any idea what to try ?

--
Matej


Mime
View raw message