roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave <snoopd...@gmail.com>
Subject Re: Show-stopping problem loading the rendering factories
Date Mon, 13 Apr 2009 12:09:38 GMT
On Sun, Apr 12, 2009 at 11:53 PM, George Frink
<southern@southernconnections.com> wrote:
> While installing Roller 4.0.4 on my OS X machine (Java 1.5), after
> completing the first stages of installation uneventfully.
> Pages will displayed well.  Slowly, and sometimes only after reload, but
> otherwise as expected.
> So I deployed the full roller-custom.properties, and ran headlong into a
> problem loading the rendering factories.
> Below are a few damning lines from the log file.

I've been using OS X for years with Roller on Java 1.5 and 1.6.

Sounds like a problem reading the renderer properties in the config file.

What do you mean by the "full" roller-custom.properties. You only need
to define the properties that you need to override in your
roller-custom.properties.

If you redefined the renderer properties, perhaps you introduced some
error while cut-and-pasting (line feeds or something)?

- Dave



> WARN  2009-04-12 23:32:23,548 RendererManager:<clinit> - Failed to load any
> renderer factories.  Rendering probably won't function as you expect.
> INFO  2009-04-12 23:32:23,550 RendererManager:<clinit> - Renderer Manager
> Initialized.
> ERROR 2009-04-12 23:32:23,560 PageServlet:doGet - Couldn't find renderer for
> page frontpage:Weblog
> org.apache.roller.weblogger.ui.rendering.RenderingException: No renderer
> found for template frontpage:Weblog!
>
> Thoughts?
>
> Thank you.
>
> George Frink
> gwf3@southernconnections.com
> twitter: twitter.com/gwfrink3
> blog:    www.southernconnections.com/roller
> phone: 919.341.2999
>
>
>
>
>

Mime
View raw message