roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave <snoopd...@gmail.com>
Subject Re: Build Problem Beyond My Ken
Date Fri, 06 Mar 2009 19:21:08 GMT
Based on your most recent emails, I assume you have worked past this problem?

Let us know if that is not the case.

- Dave



On Wed, Mar 4, 2009 at 1:26 AM, Terry Corbet <tcorbet@ix.netcom.com> wrote:
> I am trying to make a modification to Roller for which I could not find any simple, external
configuration variable or manipulation, so I am trying to build from the source.
>
> Version:  Latest check out from SVN says it is REv 749871
> App Server:  Tomcat 6.x
> Datbase:  MySQL 5.2.x
> Java Version:  1.6.x
> OS:  XP Pro
> Browser:  FF 3.x
>
> ant rebuild from the apps/weblogger directory
> issues a warning about 'svn' which seems correct because I am not using svn.
> The comments in the build.xml imply that the failure is harmless, so I am
> happy that 8 seconds later, after a slew of [openjpac] warnings about which
> I understand nothing, but also seem harmless, I get this summary:
> =============================================
> build-web:
>    [mkdir] Created dir: F:\Roller\apps\weblogger\build\compile\web
>    [javac] Compiling 256 source files to F:\Roller\apps\weblogger\build\compile\web
>    [javac] Note: Some input files use or override a deprecated API.
>    [javac] Note: Recompile with -Xlint:deprecation for details.
>    [javac] Note: Some input files use unchecked or unsafe operations.
>    [javac] Note: Recompile with -Xlint:unchecked for details.
>     [copy] Copying 17 files to F:\Roller\apps\weblogger\build\compile\web
>     [copy] Copied 1 empty directory to 1 empty directory under F:\Roller\apps\weblogger\b
> uild\compile\web
>      [jar] Building jar: F:\Roller\apps\weblogger\build\lib\roller-web.jar
>
> build:
>
> rebuild:
>
> BUILD SUCCESSFUL
> Total time: 8 seconds
> =============================================
>
> So, I causiously move the two ouput jar files:
>   roller-business-jar
>   roller-web.jar
> over to Tomcat's Lib and restrart the server. with this log output result
> =============================================
> Mar 3, 2009 9:50:00 PM org.apache.catalina.core.StandardContext listenerStart
> SEVERE: Error configuring application listener of class org.apache.roller.weblogger.ui.core.RollerContext
> java.lang.NoClassDefFoundError: org/springframework/security/providers/encoding/PasswordEncoder
>  at java.lang.Class.getDeclaredConstructors0(Native Method)
>  at java.lang.Class.privateGetDeclaredConstructors(Class.java:2389)
>  at java.lang.Class.getConstructor0(Class.java:2699)
>  at java.lang.Class.newInstance0(Class.java:326)
>  at java.lang.Class.newInstance(Class.java:308)
>  at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3787)
>  at org.apache.catalina.core.StandardContext.start(StandardContext.java:4342)
>  at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
>  at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
>  at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
>  at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:926)
>  at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:889)
>  at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:492)
>  at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1149)
>  at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
>  at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
>  at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
>  at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
>  at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
>  at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
>  at org.apache.catalina.core.StandardService.start(StandardService.java:516)
>  at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
>  at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
>  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>  at java.lang.reflect.Method.invoke(Method.java:597)
>  at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
>  at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
> Caused by: java.lang.ClassNotFoundException: org.springframework.security.providers.encoding.PasswordEncoder
>  at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1387)
>  at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1233)
>  at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
>  ... 29 more
> Mar 3, 2009 9:50:00 PM org.apache.catalina.core.StandardContext listenerStart
> SEVERE: Skipped installing application listeners due to previous error(s)
> =============================================
>
> I would appreciate directions on how to proceed.  I don't believe the problem relates
> to my code change, which has to do with adding a query to see if I can get a different
> result set to use with the client side's template/velocity mechanism.  I believe that
I
> would get the same result, if I just took the output of ant's build with the pure code
checked
> out from svn.  I have no understanding of spring's 'injection' into a Servlet app, and
assumed
> that whatever libs are needed by the build process are present in the directories as
> required by that build process.  Probably I have mis-used the build process and could
> use some additional instruction.
>
> Thank you.
>
>
>

Mime
View raw message