roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave <snoopd...@gmail.com>
Subject Re: w.bloggar oddity
Date Mon, 23 Feb 2009 13:37:14 GMT
On Mon, Feb 23, 2009 at 5:58 AM, Rocco Scappatura
<Rocco.Scappatura@infracom.it> wrote:
> I've installed roller 3.1 on a W2K professional platform. I'm using
> w.bloggar as blogger client. But (I don't know since when exactly) it
> happens that after I post an article the first time and I try to update
> the same article I get an HTTP 500 error. On the Roller logs I see the
> following error:
>
> ERROR 2009-02-23 01:59:06,216 StandardWrapperValve:invoke -
> Servlet.service() for servlet RollerXMLRPCServlet threw exception
> org.apache.xmlrpc.ParseFailed: Unparseable date: "20090223T01.58.56"
>        at
> org.apache.xmlrpc.XmlRpcRequestProcessor.processRequest(Unknown Source)
>        at org.apache.xmlrpc.XmlRpcWorker.execute(Unknown Source)
>        at org.apache.xmlrpc.XmlRpcServer.execute(Unknown Source)
>        at org.apache.xmlrpc.XmlRpcServer.execute(Unknown Source)


Yes, that is rather odd. What version of wbloggar are you using?

Dates in XML-RPC are supposed to be ISO-8601, see:
   http://www.xmlrpc.com/spec
   http://www.w3.org/TR/NOTE-datetime

And that date 20090223T01.58.56" does not appear to be properly formatted.

Is there a way to configure the date format used by wbloggar?
Is there a Roller-specific setting for bloggar?

- Dave

Mime
View raw message