roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanouil Batsis (Manos)" <ma...@abiss.gr>
Subject Issues with theme resource and .vm template sharing?
Date Mon, 19 Jan 2009 20:30:40 GMT

1) I can't figure out a way to share velocity templates between themes. 
Sorry if this is a really dumb question but velocity is so new to me I'm 
not even sure whether this is a roller or a velocity question.

2) $url.themeResource does not work for me. Suppose a theme named 
"themeA" applied to a blog named "blogA", it loads it's CSS like:

$url.resource("styles/default.css")

which results in

/contextPath/blogA/resource/styles/default.css

i.e. the blog name is used instead of the theme name and it works. But, 
to load the same file from blogB using themeB, neither of these work:

$url.themeResource("themeA","styles/default.css")
$url.themeResource("blogA","styles/default.css")


which respectively produce

/myuni/themes/themeA/styles/default.css
/myuni/themes/blogA/styles/default.css

at first I thought the problem was the themes location was missing from 
the administration config UI, but it did not work even after I used the 
same value as with themes.dir from the roller-custom.properties file.

Is this a bug? I'm using 4.1.


-- 
Manos Batsis, Chief Technologist
          __    _
   ____ _/ /_  (_)_________ ____ ______
  / __ `/ __ \/ / ___/ ___// __ `/ ___/
/ /_/ / /_/ / (__  |__  )/ /_/ / /
\__,_/_.___/_/____/____(_)__, /_/
                         /____/
http://www.Abiss.gr
5, Daphnidos Street,
14122, Neo Iraklio,
Athens, Greece

Tel: +30 210 2851517

http://www.linkedin.com/in/manosbatsis

Mime
View raw message