roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Coles" <alex.co...@gmail.com>
Subject Roller 4.0 + GlassFish v3 Prelude: OpenJPA strangeness (CNFE: org.apache.openjpa.util.CacheMap)
Date Mon, 17 Nov 2008 03:42:00 GMT
I am migrating a Roller 4.0 installation from Tomcat to GlassFish v3 Prelude
(b28c, I believe). In so doing so, I came across the following strangeness:
There were errors initializing your configuration:
org.apache.openjpa.lib.util.ParseException: Instantiation of plugin
"QueryCompilationCache" with value "true" caused an error
"java.lang.IllegalArgumentException: java.lang.ClassNotFoundException:
org.apache.openjpa.util.CacheMap". The alias or class name may have been
misspelled (as it closely matches the valid plugin alias "true"), or the
class may not be available in the class path.  Valid aliases for this plugin
are: [all, false, true]
        at
org.apache.openjpa.lib.conf.Configurations.getCreateException(Configurations.java:341)
...
Caused by: java.lang.IllegalArgumentException:
java.lang.ClassNotFoundException: org.apache.openjpa.util.CacheMap

For the full log output see: http://gist.github.com/25652


I tried disabling all plugins, custom settings, and using a barebones setup.
Actually, I stole the barebones roller-custom.properties from the following
site:
http://number9.hellooperator.net/articles/2008/05/20/roller-4-on-glassfish-v3

I only got Roller + GlassFish working together, by adding the following JPA
configuration to my roller-custom.properties:
openjpa.QueryCompilationCache=false

I've fixed it, and it works, but the problem is, I am not 100% sure why it
works!
Does this look like a bug in Roller? GlassFish? Anyone who could shed some
light on this?
I also need to understand the implications of turning off
OpenJPA's QueryCompilationCache.

Thanks

Alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message