roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anil Gangolli <a...@busybuddha.org>
Subject Re: Problem with special chars like èìòù in entry permalink
Date Thu, 09 Oct 2008 14:50:58 GMT

Unfortunately, we have to look at more things, so there are many more 
questions.

Did you set up your database to store characters in UTF-8 as well?   
Make sure that the database is set up to use UTF-8 and that the jdbc URL 
for the database connection specifies UTF-8 encoding.  The installation 
guide describes how to do this for MySQL.

Do the characters in your title and in your blog entries get stored and 
retrieved properly?

What version of Roller are you using?
What version of Tomcat?

Have you made any local modifications to Roller, particularly with the 
servlet filters?  Check to make sure that CharEncodingFilter is the 
first filter mapping in the filter chain in your web.xml.

If you have modified your Velocity templates (themes)?   Do these 
characters work when you use the original themes?

--a.


Guglielmo Carandente wrote:
> I make this, but don't work other ideas??
>
> -----Messaggio originale-----
> Da: Anil Gangolli [mailto:anil@busybuddha.org]
> Inviato: mercoledì 8 ottobre 2008 16.13
> A: user@roller.apache.org
> Oggetto: Re: Problem with special chars like èìòù in entry permalink
>
>
> Omit the asterisks, which were due to translation of bolding by my mail
> client.
>
> This is a typical setup and your parameters may vary:
>
> <Connector port="8080"
>   maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
>   enableLookups="false" redirectPort="8443" debug="0"
>   acceptCount="100" connectionTimeout="20000"
>   disableUploadTimeout="true"
>   URIEncoding="UTF-8" />
>
>   


Mime
View raw message