roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric McEachern <eric_mceach...@ncsu.edu>
Subject Re: Wrong username and password combination
Date Wed, 17 Sep 2008 19:05:19 GMT
I'm experiencing the same problem, with the wrong password / username 
combo error. Which file serves as the controller for the register.rol 
page, I'd like to run the debugger on it and see what's going on under 
the hood.

Eric


Dave wrote:
> On Sat, Sep 13, 2008 at 9:46 PM, Jeremy Cowgar
> <jcowgar@advancedpricing.com> wrote:
>   
>> I setup a Roller system on Tomcat 6.0.18. Things went OK but I am having two
>> problems. Oh, I am using PostgreSQL.
>>
>> #1... When a new user signs up, they get an email with a link to click to
>> validate their email address. When they click that link, it takes them to
>> the register page with validation errors on all the fields stating they must
>> be filled in. I could never make that work. So, I disabled the need for
>> email validation until I get that problem solved.
>>     
>
> Sounds like you are using Roller 4.0 and have encountered this problem:
>    https://issues.apache.org/roller/browse/ROL-1686
>
>
>   
>> #2... Now, when a new user creates an account, it always says "Wrong
>> username and password combination". I decided to try for myself and created
>> a new account. Ineed, I cannot login. What's worse yet is I cannot login as
>> the admin user that I setup any longer. I get the same error. I looked at
>> the database and my admin username is the same username still. I then
>> created a new user w/the same password as the admin password and compared
>> what the database said for the two. The two password fields were identical
>> leading me to think that the password for the admin account is correct also.
>> The active flag was true.
>>     
>
> I'm not sure what is going on here, but you might want to check.
>
> When you looked at the database, were the passwords encrypted or were
> they readable plain text? What do you have in your
> roller-custom.properties file?  Do you see any errors appear in the
> roller.log file when you attempt a login?
>
> - Dave
>   

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message