roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frederic_deSo...@ymp.gov
Subject Re: Unable to register first user
Date Thu, 08 May 2008 15:40:56 GMT
Very weird...   Our dba says that property is indeed set to true already.

Somehow it's not reading correctly.

Some of the other values are null in the db,  but registration.enabled. Is true.

Fred

______________________________________________________________________________________________________________

This email is sent from the BlackBerry Handheld Device.

This electronic message transmission contains information from Bechtel SAIC Company, LLC.
 The information is intended solely for the use of the addressee and its use by any other
person is not authorized.  If you are not the intended recipient, you have received this communication
in error, and any review, use, disclosure, copying or distribution of the contents of this
communication is strictly prohibited.  If you have received this electronic transmission in
error, please notify the sender immediately by telephone or by electronic mail and permanently
delete the original message.





----- Original Message -----
From: "Akshay Bhatia" [Akshay.Bhatia@morse.com]
Sent: 05/08/2008 04:04 PM CET
To: <user@roller.apache.org>
Subject: RE: Unable to register first user



At database level you could try setting the following:

Table:  roller_properties

Change the value of the field where the "name" value is:

users.registration.enabled
To
True

This might work
Thanks
Akshay 

-----Original Message-----
From: Frederic deSousa/YM/RWDOE [mailto:Frederic_deSousa@ymp.gov] 
Sent: 08 May 2008 15:55
To: user@roller.apache.org
Subject: Re: Unable to register first user

Thanks Gabe.

Deployed via Tomcat Manager to   /rolldev

Here is the properties file... 

##started off as auto, then changed to manual installation.type=manual
database.configurationType=jdbc
database.jdbc.driverClass=oracle.jdbc.OracleDriver
database.jdbc.connectionURL=jdbc:oracle:thin:docutest1/password@//******
rolldev.ymp.gov:1521/rolldev.********.gov
database.jdbc.username=*******
database.jdbc.password=*******
mail.configurationType=properties
mail.hostname=smtp.***.gov
##Dialect added as an attempt to fix issues.... 
hibernate.dialect=org.hibernate.dialect.OracleDialect
log4j.category.org.apache.roller=DEBUG
log4j.category.net.java.roller=DEBUG


Thanks for any help,

Fred



Please respond to user@roller.apache.org

To:     user@roller.apache.org
cc:      (bcc: Frederic deSousa/YM/RWDOE)
Subject:        Re: Unable to register first user
LSN: Not Relevant
User Filed as: Not a Record

1) Did you create a roller-custom.properties, if so feel free to share
it with us
2) per the message

/rollerdev/roller-ui/users.registration.url
did you install as /roller or as /rollerdev context?


Frederic deSousa/YM/RWDOE wrote:
> Update:  this is from roller.log.    Seems to be a problem to me.... 
where 
> can these values be changed and why are they null?
>
> --snip--
>
> DEBUG 2008-05-07 16:24:59,741 WebloggerConfig:getProperty - Fetching 
> property [users.registration.enabled=null]
> DEBUG 2008-05-07 16:24:59,874 WebloggerRuntimeConfig:getProperty - 
fetched 
> property [users.registration.enabled=null]
> DEBUG 2008-05-07 16:24:59,887 WebloggerConfig:getProperty - Fetching 
> property [users.registration.url=null]
> DEBUG 2008-05-07 16:25:00,030 WebloggerRuntimeConfig:getProperty - 
fetched 
> property [users.registration.url=null]
> DEBUG 2008-05-07 16:25:00,040 WebloggerConfig:getProperty - Fetching 
> property [users.registration.url=null]
> DEBUG 2008-05-07 16:25:00,047 WebloggerRuntimeConfig:getProperty - 
fetched 
> property [users.registration.url=null]
>
> Fred
>
>
> Please respond to user@roller.apache.org
>
> To:     user@roller.apache.org
> cc:      (bcc: Frederic deSousa/YM/RWDOE)
> Subject:        Re: Unable to register first user
> LSN: Not Relevant
> User Filed as: Not a Record
>
> Thanks, Gabe.
>
> When I go to  /roller/roller-ui/menu.rol   and click the Register
link, 
I 
>
> get the following 404:
> ==========
> Status Code 404 
> Message /rollerdev/roller-ui/users.registration.url 
> Type 
> Exception The file that you requested could not be found on this
server. 

> =============
>
>
> Am I missing a file that's supposed to be there?
>
> The /roller_data/ folder is 777 and it has a /search-index folder 
inside, 
> but no /resources folder yet. 
>
> I also see a "ERROR setting database version"   in the roller log.
>
> Thanks again,
> Fred
>
>
>
> Please respond to user@roller.apache.org
>
> To:     user@roller.apache.org
> cc:      (bcc: Frederic deSousa/YM/RWDOE)
> Subject:        Re: Unable to register first user
> LSN: Not Relevant
> User Filed as: Not a Record
>
> Frederic deSousa/YM/RWDOE wrote:
> 
>> Sorry, should have mentioned this is Roller 4.0 running on Tomcat 
5.5.17 
>> 
>
>
> 
>> connecting to Oracle 10g.
>>
>> Please respond to user@roller.apache.org
>>
>> To:     user@roller.apache.org
>> cc:      (bcc: Frederic deSousa/YM/RWDOE)
>> Subject:        Unable to register first user
>> LSN: Not Relevant
>> User Filed as: Not a Record
>>
>> When I try to register my first user, Roller returns a page that says

>> 
> "The 
> 
>> administrator of this site has disabled user registrations at this 
time. 
>> 
>
>
> 
>> Please contact the system administrators if you think this is 
>> 
> incorrect."
> 
>> How do I enable user registrations?
>>
>> Thx
>>
>>
>>
>> 
> Hi Frederic,
> This is a Oracle specific problem. The workaround is to use a URL
like:
> http://yourdomain/roller/roller-ui/menu.rol
> Detailed discussion on this issue can be found at the following Link:
> http://markmail.org/message/n4juthukgfwmwcie
>
> 


-- 
Regards

Gabe Wong
NGASI AppServer Manager
JAVA AUTOMATION and SaaS Enablement
http://www.ngasi.com
NEW! 8.1 - Centrally manage Application Servers across multiple physical

servers





 Click
https://www.mailcontrol.com/sr/wQw0zmjPoHdJTZGyOCrrhg==
mmvTYHGOi8ffDXL4vxOLAW6a19lw9mtxvalpYdScFxEUA==  to report this email as
spam.


If you have received this e-mail in error, please return it to the sender immediately and
delete it and any attachments from your system. Morse plc is the UK holding company for various
international subsidiaries trading as Morse. The registered office for Morse Group Limited
(Company Number 2212268) and its UK group undertakings is Profile West, 950 Great West Road,
Brentford, Middlesex TW8 9EE.  VAT Registration 673 0084 47.

Mime
View raw message