roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Haslam <simon_has...@yahoo.co.uk>
Subject RE: Oracle configuration problem
Date Wed, 21 May 2008 09:16:33 GMT


Timothy Mizas wrote:
> 
> I managed to get roller working fine with no issues on my personal
> machine. But as soon as I move it to the red hat server, with the same
> settings, I still get this in roller.log
> 
> java.sql.SQLException: ORA-00604: error occurred at recursive SQL level 1
> ORA-12705: invalid or unknown NLS parameter value specified
> 
> It says DriverManager.getConnection() is throwing this error. I've tried
> completely turning off the firewall to make sure it was able to freely
> connect too. Has anyone been able to get roller working on RHEL 5?
> 

Yes, I've got Roller running on RHEL5 (actually OEL5) and to 10.2 of the
database but using OC4J 10.1.3 instead of Tomcat.

Have you looked on Metalink, e.g. notes 158654.1 "ORA-12705 - Common Reasons
and How to Resolve Them" and 21558.1 "OERR: ORA 12705 "invalid or unknown
NLS parameter value specified""? You don't say what locale you're in etc but
have you tried NLS_LANG = AMERICAN_AMERICA.US7ASCII (the default)? When you
say it worked fine on your PC how different is that environment - Windows or
Linux, did you have an Oracle client installed on it, is it in the same
subnet as the app server, etc?

Finally have you tried writing a small, standalone java test program to
prove that you can connect to the database using the same driver/connection
URL. This would then indicate whether the problem is in Roller/Tomcat
configuration.

:Simon
-- 
View this message in context: http://www.nabble.com/Oracle-configuration-problem-tp17325911s12275p17359243.html
Sent from the Roller - User mailing list archive at Nabble.com.


Mime
View raw message