roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave <snoopd...@gmail.com>
Subject Re: Custom theme failing even before any changes (Roller 4.0, Oracle AS/OC4J 10.1.3, Oracle 10.2 db)
Date Sat, 19 Apr 2008 17:09:06 GMT
On Fri, Apr 18, 2008 at 6:37 AM, Simon Haslam <simon_haslam@yahoo.co.uk> wrote:
>  I've been trying for the first time to customise a roller 4.0 blog (running
>  on Oracle AS/OC4J 10.1.3, with Oracle 10.2 database - the way I installed it
>  is discussed in the mailing list archives).
>
>  I started with theme "Clean" (though have tried others too) then went to
>  Maintenance and changed "Shared Theme" to "Custom Theme". I didn't tick "I
>  want to copy the templates..." (though have tried that too).
>
>  When I change to a Custom Theme it says "Successfully set theme to -
>  custom". I don't see any errors in the log.
>
>  However if I try to go to the front page of the blog (this is a different
>  browser, not logged in) I get an HTTP 500 - this is the end of the roller
>  log:
>
>  ,127 WeblogPageCache:get - HIT-EXPIRED cache.weblogpage:fmw/page=0
>  ,130 PageServlet:doGet - MISS cache.weblogpage:fmw/page=0
>  ,132 PageServlet:doGet - Looking for template to use for rendering
>  ,150 PageServlet:doGet - page found, dealing with it
>  ,152 PersistenceSessionFilter:doFilter - Releasing Roller Session
>  <<<<<<<<???
>  ,154 WebloggerConfig:getProperty - Fetching property
>  [planet.aggregator.enabled=false]
>  ,229 CharEncodingFilter:doFilter - Processing CharEncodingFilter
>  ,229 CharEncodingFilter:doFilter - Set request character encoding to UTF-8
>  ,232 BootstrapFilter:doFilter - Entered /roller/roller-ui/styles/roller.css
>  ,233 PersistenceSessionFilter:doFilter - Entered
>  /roller/roller-ui/styles/roller.css
>  ,234 RequestMappingFilter:doFilter - entering
>  ,235 RequestMappingFilter:doFilter - trying mapper
>  org.apache.roller.weblogger.ui.rendering.WeblogRequestMapper
>  ,237 WeblogRequestMapper:handleRequest - evaluating
>  [/roller/roller-ui/styles/roller.css]
>  ,238 WeblogRequestMapper:handleRequest - potential weblog handle = roller-ui
>  ,239 WeblogRequestMapper:handleRequest - SKIPPED roller-ui
>  ,240 RequestMappingFilter:doFilter - request not mapped
>  ,243 RequestMappingFilter:doFilter - exiting
>  ,244 PersistenceSessionFilter:doFilter - Releasing Roller Session
>  ,246 WebloggerConfig:getProperty - Fetching property
>  [planet.aggregator.enabled=false]
>  ,247 PersistenceSessionFilter:doFilter - Exiting
>  /roller/roller-ui/styles/roller.css
>  ,248 BootstrapFilter:doFilter - Exiting /roller/roller-ui/styles/roller.css
>
>  I haven't found any actual java errors, e.g. nothing in the container log.

Hi Simon,

You could still be hitting an Oracle-related bug. It's hard to tell
without some error messages. You might be able to get better feedback
if you turn on debugging for the theme subsystem. Add this to your
roller-custom.properties file:

    log4j.category.org.apache.roller.weblogger.business.themes=DEBUG

And try customizing a theme.

- Dave

Mime
View raw message