roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Haslam <simon_has...@yahoo.co.uk>
Subject Re: Custom theme failing even before any changes (Roller 4.0, Oracle AS/OC4J 10.1.3, Oracle 10.2 db)
Date Mon, 21 Apr 2008 09:48:31 GMT



Simon Haslam wrote:
> 
> ...
> 52,588 PersistenceSessionFilter:doFilter - Exiting
> /roller/roller-ui/styles/roller.css
> 52,590 BootstrapFilter:doFilter - Exiting
> /roller/roller-ui/styles/roller.css
> ...
> I know it's not reporting an error in the log, but could this be a path
> problem as I've had those before? (I'm setting my themes.dir etc in my
> roller-custom.properties). I'll see if I can find in the source where
> roller.css is being called.
> 

Hmmm, I found this ref in tiles/head.jsp:
<link rel="stylesheet" type="text/css" media="all" href='<s:url
value="/roller-ui/styles/roller.css"/>' />

If I try to access it from the browser it's fine. Maybe that's a red
herring. 

Looking at my oc4j log again I get these messages at startup:
--------
08/04/21 09:08:54 Start process
--------
09:09:30,810 INFO   - Root WebApplicationContext: initialization started
09:09:31,005 INFO   - JDK 1.4+ collections available
09:09:31,040 INFO   - Commons Collections 3.x available
09:09:31,108 INFO   - Loading XML bean definitions from ServletContext
resource [/WEB-INF/security.xml]
09:09:31,710 INFO   - Bean factory for application context [Root
WebApplicationContext]:
org.springframework.beans.factory.support.DefaultListableBeanFactory
defining beans
[filterChainProxy,filterInvocationInterceptor,authenticationManager,loggerListener,daoAuthenticationProvider,jdbcAuthenticationDao,userCache,anonymousAuthenticationProvider,roleVoter,accessDecisionManager,httpSessionContextIntegrationFilter,authenticationProcessingFilter,anonymousProcessingFilter,exceptionTranslationFilter,remoteUserFilter,authenticationProcessingFilterEntryPoint,rememberMeProcessingFilter,rememberMeServices,rememberMeAuthenticationProvider,channelProcessingFilter,channelDecisionManager];
root of BeanFactory hierarchy
09:09:31,778 INFO   - 21 beans defined in application context [Root
WebApplicationContext]
09:09:31,809 INFO   - Unable to locate MessageSource with name
'messageSource': using default
[org.springframework.context.support.DelegatingMessageSource@d70b42]
09:09:31,816 INFO   - Unable to locate ApplicationEventMulticaster with name
'applicationEventMulticaster': using default
[org.springframework.context.event.SimpleApplicationEventMulticaster@179c0a7]
09:09:31,907 INFO   - Unable to locate ThemeSource with name 'themeSource':
using default
[org.springframework.ui.context.support.ResourceBundleThemeSource@351f6d]
09:09:31,995 INFO   - Pre-instantiating singletons in factory
[org.springframework.beans.factory.support.DefaultListableBeanFactory
defining beans
[filterChainProxy,filterInvocationInterceptor,authenticationManager,loggerListener,daoAuthenticationProvider,jdbcAuthenticationDao,userCache,anonymousAuthenticationProvider,roleVoter,accessDecisionManager,httpSessionContextIntegrationFilter,authenticationProcessingFilter,anonymousProcessingFilter,exceptionTranslationFilter,remoteUserFilter,authenticationProcessingFilterEntryPoint,rememberMeProcessingFilter,rememberMeServices,rememberMeAuthenticationProvider,channelProcessingFilter,channelDecisionManager];
root of BeanFactory hierarchy]
09:09:32,234 INFO   - Initializing EHCache CacheManager
09:09:32,346 INFO   - Creating new EHCache cache region 'userCache'
09:09:32,571 INFO   - Validated configuration attributes
09:09:32,985 INFO   - Validated configuration attributes
09:09:32,986 INFO   - Using context class
[org.springframework.web.context.support.XmlWebApplicationContext] for root
WebApplicationContext
09:09:32,987 INFO   - Root WebApplicationContext: initialization completed
in 2179 ms
08/04/21 09:09:32 Roller Weblogger: Successfully loaded custom properties
file from classpath
08/04/21 09:09:55 Oracle Containers for J2EE 10g (10.1.3.3.0)  initialized

They have been like this since I first got roller running, but I wonder
whether "Unable to locate ThemeSource with name 'themeSource': using default
[org.springframework.ui.context.support.ResourceBundleThemeSource@351f6d]"
is only important for Custom themes?

Is there any other logging I can turn on so that we can see what it's doing
prior to the HTTP 500?

Thanks again!
Simon
-- 
View this message in context: http://www.nabble.com/Custom-theme-failing-even-before-any-changes-%28Roller-4.0%2C-Oracle-AS-OC4J-10.1.3%2C-Oracle-10.2-db%29-tp16763352s12275p16806474.html
Sent from the Roller - User mailing list archive at Nabble.com.


Mime
View raw message