roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Lozano <jacobloz...@carkernel.org>
Subject Re: roller with https
Date Mon, 31 Mar 2008 19:00:18 GMT
I found the solution to this issue.

In Server Admin | Site Settings I set the "Absolute URL to site" setting
to be our url with https. This enabled all URL's which were absolute to
be written with https.


Jacob Lozano wrote:
> Hi Dave,
> 
> Thanks for your response.
> 
> I had previously tried using the built-in schemeenforcement in
> roller-custom.properties.
> 
> I looked at acegi after seeing your response. I think acegi will also be
> doing a rewrite - just like my current apache rewrite. And so I don't
> think it is the answer.
> 
> What seems to be the problem is that the comments page uses absolute
> URLs starting with http://.
> 
> I've noticed that unlike comments, the New Blog Post pages use relative
> URLs and so send requests with https:// at the beginning.
> 
> Is there a reason the comments page encodes absolute URLs? Is there a
> way to make it use relative URL's?
> 
> And short of relative URL's, would there be a way to make it encode the
> comments post URLs with https instead of http?
> 
> Thanks,
> Jacob
> 
> Dave wrote:
>> On Fri, Mar 28, 2008 at 12:18 AM, Jacob Lozano
>> <jacoblozano@carkernel.org> wrote:
>>> Roller Users: I'm using:
>>>  Roller 4.0
>>>  Tomcat 5.5
>>>  mysql 5.0
>>>  Java 1.6
>>>  Linux ubuntu 7.10
>>>
>>>  I'm using apache https to route to my roller installation on tomcat.
>>>
>>>  When I post a comment, roller is posting to
>>>  /roller/blog/entry/title_of_post using plain http and then when it
>>>  redirects to https the comment is getting lost.
>>>
>>>  I've tried using schemeenforcement but that did not work.
>>>
>>>  It's possible I did not set the schemeenforcement pattern correctly.
>>>  Since the last part of the url varies, I must use some kind of wildcard.
>>>
>>>  /**/entry/* did not work. Other attempts did not work.
>>>
>>>  Any help would be much appreciated. Thanks!
>> Did you try Roller's built-in scheme enforcement via roller-custom.properties?
>>
>> Or did you do something in the Acegi config. file (security.xml)?
>>
>> - Dave
>>
> 


Mime
View raw message