roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave <snoopd...@gmail.com>
Subject Re: Roller 4.0 and Roller Planet Issue
Date Fri, 04 Jan 2008 21:39:58 GMT
On Jan 4, 2008 3:49 PM, Nate Keegan <nate.keegan@cityofprescott.net> wrote:
> I keep seeing this in the logs:
>
> DEBUG 2008-01-04 13:31:00,146 TaskScheduler:runTasks -
> RefreshRollerPlanetTask: next allowed run time = Wed Dec 31 17:05:00 MST
> 1969
> DEBUG 2008-01-04 13:31:00,146 TaskScheduler:runTasks - MISSED last run,
> checking if waiting is necessary
> DEBUG 2008-01-04 13:31:00,147 TaskScheduler:runTasks - WAITING for next
> reasonable run time
> ...

Hmm... looks like the tasklock table has some bad data in it.  I heard
about that at least once before here on the list. What database are
you using?

To work around this problem, try removing all rows from the
roller_tasklock table via SQL, i.e. "delete from roller_tasklock" That
should allow the task to run, feeds to be fetched and parsed into data
in the rag_entry table.


> My directories:
>
> [root@viking classes]# more planet-custom.properties
> cache.dir=/opt/SUNWappserver/domains/domain1/roller_data/cache
> output.dir=/opt/SUNWappserver/domains/domain1/roller_data/webapp
> template.dir=/opt/SUNWappsserver/domains/domain1/roller_data/templates
> [root@viking /]# ls /opt/SUNWappserver/domains/domain1/roller_data/cache/
> total 44
> drwxr-xr-x   2 root     root         512 Jan  3 11:27 .
> drwxr-xr-x   5 root     root         512 Jan  2 15:43 ..
> -rw-r--r--   1 root     root       15683 Jan  4 13:00
> feed_http___viking_8080_roller_planet_feed_entries_rss
> -rw-r--r--   1 root     root        3290 Jan  4 13:00
> feed_http___viking_8080_roller_planetrss
>
> It looks like there is data being collected.


Yes, it looks like it ran at least once. Are there any entries in the
rag_entry table?

- Dave

Mime
View raw message