roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nate Keegan <nate.kee...@cityofprescott.net>
Subject Re: Roller 4.0 and Roller Planet Issue
Date Thu, 03 Jan 2008 18:57:11 GMT
I changed RefreshPlanetRollerTask to RefreshRollerPlanetTask and 
restarted my web container.

Based on the release note changes my setup is consistent although I am 
still not sure if I need to subscribe to my site for a situation where 
all blogs are contained in Roller (i.e. no external blogs to aggregate).

I am still not seeing anything on my front page blog.

Server admin > Handle of weblog to serve as frontpage blog is planet
Server admin > Enable aggregated site-wide frontpage is checked
Server admin > Absolute URL to site is http://viking:8080/roller/ 
(doesn't seem to matter if it is roller or roller/ on the end)
Planet settings > Absolute URL to Planet page is 
http://viking:8080/roller/planet
Planet settings > Subscriptions > http://viking:8080/roller/planetrss 
(do I even need this?)

I cranked up the debug level and here is what I am seeing in roller.log:

DEBUG 2008-01-03 11:43:37,586 WebloggerRuntimeConfig:getProperty - 
fetched property [site.frontpage.weblog.aggregated=true]
DEBUG 2008-01-03 11:43:37,607 WebloggerRuntimeConfig:getProperty - 
fetched property [site.frontpage.weblog.handle=planet]
DEBUG 2008-01-03 11:43:37,610 WeblogRequest:<init> - parsing path /planet
DEBUG 2008-01-03 11:43:37,612 WeblogRequest:<init> - handle = planet
DEBUG 2008-01-03 11:43:37,615 WeblogRequest:<init> - locale = null
DEBUG 2008-01-03 11:43:37,618 WeblogRequest:<init> - pathInfo = null
DEBUG 2008-01-03 11:43:37,620 WeblogPageRequest:<init> - parsing path null
DEBUG 2008-01-03 11:43:37,623 WeblogPageRequest:<init> - context = null
DEBUG 2008-01-03 11:43:37,626 WeblogPageRequest:<init> - weblogAnchor = null
DEBUG 2008-01-03 11:43:37,628 WeblogPageRequest:<init> - weblogDate = null
DEBUG 2008-01-03 11:43:37,631 WeblogPageRequest:<init> - weblogCategory 
= null
DEBUG 2008-01-03 11:43:37,634 WeblogPageRequest:<init> - tags = null
DEBUG 2008-01-03 11:43:37,637 WeblogPageRequest:<init> - weblogPage = null
DEBUG 2008-01-03 11:43:37,639 WeblogPageRequest:<init> - pageNum = 0
DEBUG 2008-01-03 11:43:37,642 JPAUserManagerImpl:getWebsiteByHandle - 
weblogHandleToId CACHE HIT - planet
DEBUG 2008-01-03 11:43:37,645 WebloggerRuntimeConfig:getProperty - 
fetched property [site.frontpage.weblog.aggregated=true]
DEBUG 2008-01-03 11:43:37,648 WebloggerRuntimeConfig:getProperty - 
fetched property [site.frontpage.weblog.handle=planet]
DEBUG 2008-01-03 11:43:37,650 ModDateHeaderUtil:respondIfNotModified - 
since date = 1199384911000
DEBUG 2008-01-03 11:43:37,653 ModDateHeaderUtil:respondIfNotModified - 
last mod date (trucated to seconds) = 1199385817000
DEBUG 2008-01-03 11:43:37,656 SiteWideCache:get - HIT 
cache.sitewide:page/planet/page=0
DEBUG 2008-01-03 11:43:37,659 PageServlet:doGet - HIT 
cache.sitewide:page/planet/page=0

And then this:

DEBUG 2008-01-03 11:46:40,276 BootstrapFilter:doFilter - Entered 
/roller/planet/
DEBUG 2008-01-03 11:46:40,277 PersistenceSessionFilter:doFilter - 
Entered /roller/planet/
DEBUG 2008-01-03 11:46:40,282 WeblogRequestMapper:handleRequest - 
evaluating [/roller/planet/]
DEBUG 2008-01-03 11:46:40,284 WeblogRequestMapper:handleRequest - 
potential weblog handle = planet
DEBUG 2008-01-03 11:46:40,286 WeblogRequestMapper:isWeblog - checking 
weblog handle planet
DEBUG 2008-01-03 11:46:40,315 JPAUserManagerImpl:getWebsiteByHandle - 
weblogHandleToId CACHE HIT - planet
DEBUG 2008-01-03 11:46:40,317 WeblogRequestMapper:handleRequest - 
WEBLOG_URL /planet/
DEBUG 2008-01-03 11:46:40,319 WeblogRequestMapper:calculateForwardUrl - 
planet,null,null,null
DEBUG 2008-01-03 11:46:40,321 WeblogRequestMapper:calculateForwardUrl - 
FORWARD_URL /roller-ui/rendering/page/planet
DEBUG 2008-01-03 11:46:40,322 WeblogRequestMapper:handleRequest - 
forwarding to /roller-ui/rendering/page/planet
DEBUG 2008-01-03 11:46:40,332 PageServlet:processReferrer - processing 
referrer for /roller/roller-ui/rendering/page/planet
DEBUG 2008-01-03 11:46:40,335 WeblogRequest:<init> - parsing path /planet
DEBUG 2008-01-03 11:46:40,337 WeblogRequest:<init> - handle = planet
DEBUG 2008-01-03 11:46:40,406 WebloggerRuntimeConfig:getProperty - 
fetched property [site.frontpage.weblog.handle=planet]
DEBUG 2008-01-03 11:46:40,408 WeblogRequest:<init> - parsing path /planet
DEBUG 2008-01-03 11:46:40,411 WeblogRequest:<init> - handle = planet
DEBUG 2008-01-03 11:46:40,440 JPAUserManagerImpl:getWebsiteByHandle - 
weblogHandleToId CACHE HIT - planet
DEBUG 2008-01-03 11:46:40,446 WebloggerRuntimeConfig:getProperty - 
fetched property [site.frontpage.weblog.handle=planet]
DEBUG 2008-01-03 11:46:40,454 ModDateHeaderUtil:respondIfNotModified - 
NOT MODIFIED http://viking:8080/roller/roller-ui/rendering/page/planet

And this:

DEBUG 2008-01-03 11:50:00,175 TaskScheduler:runTasks - 
RefreshRollerPlanetTask: next allowed run time = Wed Dec 31 17:05:00 MST 
1969
DEBUG 2008-01-03 11:50:00,175 TaskScheduler:runTasks - MISSED last run, 
checking if waiting is necessary
DEBUG 2008-01-03 11:50:00,176 TaskScheduler:runTasks - WAITING for next 
reasonable run time
DEBUG 2008-01-03 11:50:00,194 RollerTaskWithLeasing:run - PingQueueTask: 
Lease NOT acquired, cannot continue
DEBUG 2008-01-03 11:50:00,197 TaskScheduler:runTasks - SyncWebsitesTask: 
next allowed run time = Thu Jan 01 17:00:00 MST 1970
DEBUG 2008-01-03 11:50:00,198 TaskScheduler:runTasks - MISSED last run, 
checking if waiting is necessary
DEBUG 2008-01-03 11:50:00,198 TaskScheduler:runTasks - WAITING for next 
reasonable run time
DEBUG 2008-01-03 11:50:00,199 TaskScheduler:runTasks - Finished



Dave wrote:
> On Jan 3, 2008 11:06 AM, Nate Keegan <nate.keegan@cityofprescott.net> wrote:
>   
>> I think that I am having a hard time getting my head around all of the
>> pieces necessary for Planet Roller.
>>
>> Here is what I have but I am seeing nothing on my front page blog.
>>
>> I am guessing that something that I am doing is incorrect or off somewhere.
>>
>> It may be that I should contact Covalent to work this out...want to be
>> sure that I don't have anything just flat out wrong/incorrect in my
>> configuration and understanding of how this works.
>>
>> Scenario - blog1 will be the front page blog and will aggregate entries
>> on other blogs on my site such as blog2 (CEO) and blog3 (CFO)
>>
>> 1. roller-custom.properties - pretty straightforward
>>
>> planet.aggregator.enabled=true
>> planet.aggregator.cache.dir=/opt/SUNWappserver/domains/domain1/roller_data/cache
>> tasks.enabled=ScheduledEntriesTask,ResetHitCountsTask,TurnoverReferersTask,
>> PingQueueTask,RefreshPlanetRollerTask,SyncWebsitesTask
>>     
>
> Try replacing 'RefreshPlanetRollerTask' with 'RefreshRollerPlanetTask'
>
> I added a note about this to the release notes here:
> http://cwiki.apache.org/confluence/display/ROLLER/Roller+4.0+Release+Notes
>
> - Dave
>   

Mime
View raw message