roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Haslam <simon_has...@yahoo.co.uk>
Subject Re: Roller 4.0 RC9 installation problem on OAS 10.1.3.3.0 (OC4J)
Date Fri, 18 Jan 2008 16:52:00 GMT

Progress!!!

Simon Haslam wrote:
> 
> I've attempted to override the uploads.dir, themes.dir and
> search.index.dir in roller-custom.properties without success. However when
> I set debug-level logging I don't see any:
> WebloggerConfig:getProperty - Fetching property [themes.dir=...]
> messages before the failure so maybe it's not attempting to read them at
> that point.
> 

Please ignore the getRealPath() comments - I think that might be a red
herring. Roller is definitely reading the properties and so, as they are not
set to "${webapp.context}", the null context should be irrelevant.

The problem appeared to be related to the auto setup of the database. I
couldn't work out why, but I think it was possibly failing in
DatabaseInstaller.isCreationRequired(). The workaround was to manually
install the schema objects (using dbscripts/oracle/createdb.sql in sqlplus)
and then set installation.type=manual in roller-custom.properties.

So far, so good. The next problem was related using the JDBC pooled driver
(oracle.jdbc.pool.OracleDataSource) where I got:
"org.apache.openjpa.persistence.PersistenceException: Invalid Oracle URL
specified: OracleDataSource.makeURL"
I've seen this before so will have to dig out my notes on it - in the
meantime I used oracle.jdbc.driver.OracleDriver with
database.jdbc.connectionURL=jdbc:oracle:thin:@<myhost>:<myport>:<mysid>
and
that was OK.

So, it went through "Bootstrapping Roller Weblogger business tier" which
looked OK, it found my search-index dir and then my themes dir. After that
lots of "initializeMissingProps - Found uninitialized property site.name ...
setting value to [Roller Site]" type of messages... and so on. This all
looked quite healthy I think.

Anyway, the upshot is it still isn't quite there. When I go to the /roller
URL I get the "Roller has encountered and logged an unexpected exception."
500 error page. The logs show this (all DEBUG messages with timestamp
removed):

 CharEncodingFilter:doFilter - Processing CharEncodingFilter
 CharEncodingFilter:doFilter - Set request character encoding to UTF-8
 BootstrapFilter:doFilter - Entered /roller/
 PersistenceSessionFilter:doFilter - Entered /roller/
 RequestMappingFilter:doFilter - entering
 RequestMappingFilter:doFilter - trying mapper
org.apache.roller.weblogger.ui.rendering.WeblogRequestMapper
 WeblogRequestMapper:handleRequest - evaluating [/roller/]
 WeblogRequestMapper:handleRequest - potential weblog handle =
 WeblogRequestMapper:isWeblog - checking weblog handle
 WeblogRequestMapper:handleRequest - SKIPPED
 RequestMappingFilter:doFilter - request not mapped
 WebloggerRuntimeConfig:getProperty - fetched property
[site.frontpage.weblog.handle=null]
 PersistenceSessionFilter:doFilter - Releasing Roller Session
 WebloggerConfig:getProperty - Fetching property
[planet.aggregator.enabled=false]
 CharEncodingFilter:doFilter - Processing CharEncodingFilter
 CharEncodingFilter:doFilter - Set request character encoding to UTF-8
 BootstrapFilter:doFilter - Entered /roller/roller-ui/styles/roller.css
 PersistenceSessionFilter:doFilter - Entered
/roller/roller-ui/styles/roller.css
 RequestMappingFilter:doFilter - entering
 RequestMappingFilter:doFilter - trying mapper
org.apache.roller.weblogger.ui.rendering.WeblogRequestMapper
 WeblogRequestMapper:handleRequest - evaluating
[/roller/roller-ui/styles/roller.css]
 WeblogRequestMapper:handleRequest - potential weblog handle = roller-ui
 WeblogRequestMapper:handleRequest - SKIPPED roller-ui
 RequestMappingFilter:doFilter - request not mapped
 RequestMappingFilter:doFilter - exiting
 PersistenceSessionFilter:doFilter - Releasing Roller Session
 WebloggerConfig:getProperty - Fetching property
[planet.aggregator.enabled=false]
 PersistenceSessionFilter:doFilter - Exiting
/roller/roller-ui/styles/roller.css
 BootstrapFilter:doFilter - Exiting /roller/roller-ui/styles/roller.css

...it doesn't feel that far away from working...

Simon

-- 
View this message in context: http://www.nabble.com/Roller-4.0-RC9-installation-problem-on-OAS-10.1.3.3.0-%28OC4J%29-tp13714430s12275p14949380.html
Sent from the Roller - User mailing list archive at Nabble.com.


Mime
View raw message