roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Haslam <simon_has...@yahoo.co.uk>
Subject Re: Roller 4.0 RC9 installation problem on OAS 10.1.3.3.0 (OC4J)
Date Thu, 17 Jan 2008 11:17:56 GMT

I forgot to mention that I deployed roller by creating a WAR file and then
uploading it through ASC (the OAS web UI). This might be different from
others who deploy it by pointing at the roller directory.

Perhaps my problem is somewhere around the servletContext.getRealPath("/")
call in RollerContext.contextInitialized? I found someone else trying to
deploy a war file to Weblogic and they were finding that this was returning
null (in fact Dave might have said something to that effect too).

By the way: I forgot to mention for other OAS users that you need to put
log4j-1.2.15.jar into the classpath (e.g. j2ee/roller/applib) and untick the
Apache.commons.logging 1.0.4 library when deploying (see Metalink note
460448.1 "java.lang.NoClassDefFoundError: org/apache/log4j/Category after
upgrading from 10.1.3.1 to 10.1.3.3"
Unpublished Bug 5871305 : APACHE.COMMONS.LOGGING LIBRARY HAS DEPENDENCY ON
LOG4J CLASSES In the OC4J class loading framework, by default, system level
shared library takes precedence to that of application defined shared
library. commons-logging.jar is defined as a system level shared library in
OC4J. This shared library has a dependency on log4j.x.jar file which has not
been properly declared. This bug is scheduled to be fixed in 10.1.3.4).

If I ever get this working I'll put together some instructions...
-- 
View this message in context: http://www.nabble.com/Roller-4.0-RC9-installation-problem-on-OAS-10.1.3.3.0-%28OC4J%29-tp13714430s12275p14916810.html
Sent from the Roller - User mailing list archive at Nabble.com.


Mime
View raw message